No longer able to logon to admin
#1
Hey all

   I have the latest version running and something happened. Now I have an inability to logon on to my MYbb Admin, it states its locked and will not send me an e-mail to unlock it.  If I go the server end and update the admin user and password, the server looks as if it took the new info but when I try to login it states wrong username an password.

  Also I tried all the saved backups going back a year and still cant login.

   Not sure how to fix this one or where to start.

  People are still able to create new accounts, I just cant get in under my admin rights

   any thoughts?


  www.brewtubers.net/btforums

Gary
Reply
#2
(2018-12-11, 07:23 PM)gafortin Wrote: Hey all

   I have the latest version running and something happened. Now I have an inability to logon on to my MYbb Admin, it states its locked and will not send me an e-mail to unlock it.  If I go the server end and update the admin user and password, the server looks as if it took the new info but when I try to login it states wrong username an password.

  Also I tried all the saved backups going back a year and still cant login.

   Not sure how to fix this one or where to start.

  People are still able to create new accounts, I just cant get in under my admin rights

   any thoughts?


  www.brewtubers.net/btforums
Did you set this up correctly? (first screenshot)

Including the cookie domain and path? This is in the AdminCP → Board Settings → Site Details

Did you check the settings.php in your root (could be public_html)/inc → settings.php
(line number may be different from yours, but the setting line code will be the same)

Take notice of how the settings in the AdminCp and the Settings.php are the same.

[Image: 5aebfc295ae9acfe402c021a1b4951be.png]


[Image: 1c642e6214110958f95f43545ae9fa4d.png]
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply
#3
Thank for the reply,

  I wish I could even get into admin CP that is what I am locked out of, If I go to my hosting site for instance godaddy, get to the MYbb setup on the server side, set my admin user/ name and save it, then go back to admin CP on mybb.admin side, it states you have the wrong user name and password.  no matter how many times or combinations I used.

 
The whole thing started when I locked myself out of my admin CP, it states it will send an email so I waited and nothing anywhere, spam, etc. I then tried several times to no avail to have it send the reset, still nothing. Then that's when I simply went to the server side to reset it, that isn't working either. So I basically can not login to my own site.

If install a fresh MYbb to my site it works fine, just the active one is not working.

I will look at the php to make they are the same.


 Not even sure where to start.


Gary
Reply
#4
Wait for sometime(Login account timeout) before logging into your account, it may have been timed out because of max login attempts.

After that try the following things :-

1. Clear all cookies or try a different browser. Also check cookie settings as Serpius mentioned. Read this document on more information on cookies
https://docs.mybb.com/1.8/development/cookies/
2. I read you tried resetting admin password but try doing resetting admin password like in this tutorial (https://wallbb.co.uk/reset-admin-password-mybb/)
3. I believe you are logging into Super admin account so verify it. Go to Admin CP and check the inc/config.php and check if the user id is same as below
$config['super_admins'] = '5';
In above example, 5 is the super admin id of my account.

Let me know what happens after this but do it after waiting for sometime.
Reply
#5
All the settings for the cookies and cookie domain is correct.

$settings['cplanguage'] = "english";
$settings['cpstyle'] = "default";
$settings['cookiedomain'] = ".brewtubers.net";
$settings['cookiepath'] = "/btforums/";
$settings['cookieprefix'] = "";
$settings['coppa'] = "disabled";

also my config is set to

$config['super_admins'] = '1';


and I attempted the to reset my password using  UPDATE mybb_users SET salt = '', password = 'YOUR_PASSWORD' WHERE uid = '1';

not sure what the 'salt' is but on the off chance that was a user name I tried that too with my password,  site replies back incorrect username and password, for both.

Also I have waited for days and weeks for a reply  to reset the password, nothing.

Let me recap

The forum has been up and running for 5 years no changes other than updates and spam addons but nothing recent

You can create a new account no issues the activation e-mail sends

reset your password works for the normal user, the reset password email sends.


When I try to login  I get on the www.brewtubers.net/btforums/admin  is get this:


This account has been locked out.
Your account is currently locked out after failing to login 5 times. You have been sent an email with instructions on how to unlock your account.

The email never sends to anything including the spam folder.

But none of that matters because when I go to the back end on the server side and reset my admin user name and password there, you know the one you set up on initial set up, that one does not work even if I try another username a password.  the only difference is instead of getting the lockout comment I get "the user name and password you entered is incorrect."


At this point I will pay someone to fix it , any takers?

Gary
Reply
#6
^ see replies here AND replies here
Reply
#7
Yeah it was already set in MyphAdmin under my username to login attempts set to 1 and failed login set to 0.

there was nothing to change the values were correct.


flipped the numbers saved it and flipped them back just to be sure, it did not work either way on 3 different browsers and two different computers one is a computer I never logged in with and it reports back 5 login attempts fail.


Anything else I can try?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)