Solved: 2 Years, 4 Months, 1 Week ago Why Is The GMT Time Offset Not Corrected After The Time Change?
#1
Solved: 2 Years, 4 Months, 1 Week ago
I noticed that my website is not showing the correct time as shown in the screenshot.

[Image: af3e22ab3bed0502be4a9017409cc8f6.png]

It is one hour off - one hour ahead. It should be reading 07:07 am.

Just so that everyone understands this, in the various time zones in the USA, we observe the Daylight Savings Time (with a few exceptions).
Twice a year, we switch back to the Standard Time Zone at the appropriate pre-set date, then we switch to the Daylight Savings Time at the appropriate pre-set date.

Currently, as of this original post, my website is in the Eastern Standard Time Zone. 

However, in the AdminCP settings as shown in the screenshot, I have the Daylight Savings Time ticked on 'Yes'. 
Also, you can see the 'Default Timezone Offset' is showing the correct time in the settings.

[Image: 63ae7a3963341dcc05b8e7f9455eeaf6.png]

So, what happened? 

Did the 'Daylight Savings Time' not work at all or what?

How do I fix this issue? 

Don't tell me that I can change the GMT to fit the Eastern Daylight Savings Time Zone, which officially becomes GMT -4 for every time we have our time changes twice a year. 
That setting 'Daylight Savings Time' should be automatically doing this, but it's not.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply
#2
Solved: 2 Years, 4 Months, 1 Week ago
i am having the exact same problem as you with Eastern Standard Time Zone.
🍦  🎀  𝐼 𝐿❤𝒱𝐸 𝑀𝒴𝐵𝐵  🎀  🍦
Reply
#3
Solved: 2 Years, 4 Months, 1 Week ago
Does anyone have any idea how to fix this issue?
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply
#4
Solved: 2 Years, 4 Months, 1 Week ago
This issue still persists.

Does anyone have any clue of what is going on?

Any solutions to fix this?
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply
#5
Solved: 2 Years, 4 Months, 1 Week ago
I know what's going on - you're not going to like it.

Reply
#6
Solved: 2 Years, 4 Months, 1 Week ago
(2019-01-11, 12:52 AM)Ben Cousins Wrote: I know what's going on - you're not going to like it.

No, that video does not offer any solutions at all. 

I'll be more specific with this screenshot.

[Image: c971a562fc5057cf08d9deb78aa97f66.png]
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply
#7
Solved: 2 Years, 4 Months, 1 Week ago
(2019-01-11, 08:09 AM)Serpius Wrote:
(2019-01-11, 12:52 AM)Ben Cousins Wrote: I know what's going on - you're not going to like it.

No, that video does not offer any solutions at all. 

If you actually watch it, it gives clear reasons as to why timezones are such a pain to program for. Solution? No. Explanation? Yes.

{$timenow} is what is set in your UCP. What's your (not the sites, your one in your UCP) timezone actually set to? GMT+what?
Reply
#8
Solved: 2 Years, 4 Months, 1 Week ago
To get an accurate time based on your location, use this option as shown in this screenshot.

Go to your UserCP and select 'Automatically detect DST settings'. Do not select 'Always Use DST Correction'.

[Image: 608edcd63ed76b4362aafde814da7348.png]
I'm Serpius and You're Not    ¯\_(ツ)_/¯
Deaf Golf
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)