Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Can't open, edit or delete saved drafts of posts
Not Solved
Using 1.8.10.

I have a user that saves drafts of posts before actually posting them.  He uses drafts a lot without issue. 

But now, he has 5 saved drafts that cannot be opened, edited or deleted.  He can create new drafts which work OK, but these 5 drafts are "stuck".

Any ideas?  Thanks.
Not Solved
Have you changed forum properties or permissions since he started the drafts that are causing problems such as changing one forum to category type?
Not Solved
Thanks for the reply.

Nope. Nothing has changed. The user has moderator permissions on one forum and has been for years.

Is there a way Admin (me) can access users Saved Drafts? I looked but didn't see how.
Not Solved
The drafts would be in the database for the forum in the table mybb_posts. To find them, you will want to search for visible = -2 because the value of -2 is used for drafts.
Not Solved
I have not done SQL in years. Is there a way (UI) to view/modify tables without running script against the table?
Not Solved
(03-14-2019, 02:10 AM)grepper Wrote: I have not done SQL in years.  Is there a way (UI) to view/modify tables without running script against the table?


to view it:

Make and download a backup of your database, open it with a text editor (Notepad++, Wordpad, etc.), and look for what dragonexpert said.

To modify it, without phpmyadmin or similar, maybe if you modify the database with the text editor and replace it with the actual one, but it's too risky.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Not Solved
(03-14-2019, 02:10 AM)grepper Wrote: I have not done SQL in years.  Is there a way (UI) to view/modify tables without running script against the table?

I use these both found below (navicat/heidisql) on all sorts of things but used the heck out of them in private game server development back in the day..., they are indeed handy. Anyhoo, so if I am understanding you, you do not have phpmyadmin or do not prefer to use it or what not but you simply are seeking a gui to allow you to view and or edit your dbs remotely and not necessarily via a browser?

Free:  * heidisql is free and handy though for win box and if you need to run on mac will require wine, if on mac and you do not want to run wine

* jHeidi has some features of heidisql and is for mac though is rather old and may be discontinued or what not. another decent mac alternative is tableplus:

Not free:       * navicat is also handy (14 day trial) and works on lin win and mac boxes
MyBB Themes Team - Making more professional themes by the hour. (Retired)
My Mods | Offer me a coffee!
Not Solved
Thanks for the suggestions folks. I will check them out. I have never heard of phpmyadmin, so no, I don't have that.

However, I still would like to know if anyone has an idea of why this user can not open, or even delete some of his drafts. As I mentioned, he can create, open, modify, post and delete other and new drafts, it's just 5 drafts that are problematic. How could those 5 records in a table be different? Seems odd to me.
Not Solved
I figured it out.  Here's how to recreate the problem:

As user#1, create a thread.
As user#2, create a response to the thread and save it as a draft.
As user#1, soft delete the first post you created in the thread.

User#2 will not be able to open or delete the saved drafts for the deleted posts.

I was able to delete the user's stuck drafts by logging in as Admin and undeleting the soft deleted thread.  I then logged in to the user's account with the stuck drafts and was able to access/delete the stuck drafts.

So, it appears that if you create a draft for a post and that post is deleted, the drafts created in reply to the deleted post are stuck and not able to be opened or deleted.

Forum Jump:

Users browsing this thread: 1 Guest(s)