Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyBB Code Works on Test but not on Actual Post
#1
Hello Folks!!!

I am currently using latest 1.8.20 MyBB with latest Php 7.3.5

I wanted to add MyCode to embed google photoslideshow.

I have created MyCode with the following 

[Image: 5p0YEX-mHZGGCAWV3Ym-BPRqLjzTcy1g4KLgrRbn...41-h606-no]
Regular Expression:


\[pgoogle\](.*?)\[/pgoogle\]


Replacement
<script src="https://cdn.jsdelivr.net/npm/[email protected]/embed-ui.min.js" async></script>
<div class="pa-carousel-widget" style="width:100%; height:480px; display:none;" data-slideshow-delay="3" data-background-color="transparent">$1</div>

I tested it in using the Sandbox Tool and it is working, wow Smile

[Image: x08bDSFbJzgUT8F-JkVWne4XdFM4pyLI7D88olTz...31-h368-no]

[Image: nEKXqgCh_2rCi-0WVX6OTnxOQ4YmpB9nQLFjGXQA...37-h554-no]
Test Value:


[pgoogle]
<img data-src="https://lh3.googleusercontent.com/ZV1Ise86N6olZqfa-DJCpXDOGSsfvbFlWIQKH4n09GTwjb5onEAcX8i6_ZXEaslGt9aZkB2h5wV5ABVixHb4qLeTsH4nfOXWtnHiDO-w5D3uVT7qtzOEpojXLsfhvFEAKgEb0w8o=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/A3dWKr2UCevpLggI5gFlbkmsdZD2ZjpjuY2hoT9yQak_s3iaAGCiBjzvVP2unQmt5nZ5IKCst7RlbBLkukraxo6xnBgX_gc667oJVMGCEKhc7TSF-zc8xPH8CRDsMrirvWDWMhha=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/Nt94vafT29I_WObrbmS2eHxBD_d0Ug0vMCwOkOWnLZmoq1KttoeZG60Lbs8gcpufcMpTpsEypkR8aAtZV2YpkDMLvXYfANoVZYrp7wAQ2hEKS6uEh6Vww7bExXR2FebPaIGiccFW=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/vdIxO0EVh5NwDRZ8FVpS475JOhWxhrQz6vEtv3XA39LTws5yNRqY3XQgLBGdNRtrl3TE2-rzTdwl5dNjrYd5zmdNBwwIj_eBpnx04bhOZNSc5vDhtpDrBy1s_eUUlx1zFPrSYusT=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/ox8qpKXXhxB3fZvxThrpGND9DuGydWtrPnvy9d4ZqLGX9I7ZcRz7rGJUJ7DNLxRTQzkYBX4JRhso3AY_9wdD7AzGmk-ftH1O-JtrIlmvFONkFRx9ijVtQapxCVm5Ou5oKKia9ULR=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/A7ln8GQksZwkLVJ84MdYK4YLCtzQM6nL1dg_DOrOvWS3IH_AOMH58O8TeTFmr-2-o_FrTLjhihMgu2rTbOnNsAvUWxSti8B7WfJ5376lsZKb3Ej_K49CCpcJoOyYWyocAt9YIiG0=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/CWuI8W_noZd2AMFmkwt-n1wkahbqo-ohHu4mIsqW4L9La2eE48Avbm11LqtLq_jer_RidSCCX8tg4JYbml50gfVBEiNV0hk3dR3UCH1FlydblsdGYlSapzbwUmuKMk_WePmmAWeA=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/1XGRTj792455ecbQs161P9NvqHYMmbmmkt-dJnM4liv1Beu3MPrQvI29XPIEpvax7Zsexm1Gh9zypdGUX4MsCFn0U9zKQ0NadEkX8748U5Y36PuP0QTCi1FPmuwkRhfko4IIjO1n=w1920-h1080" src="" alt="" />
[/pgoogle]


HTML Result:

<script src="https://cdn.jsdelivr.net/npm/[email protected]/embed-ui.min.js" async></script>
<div class="pa-carousel-widget" style="width:100%; height:480px; display:none;" data-slideshow-delay="3" data-background-color="transparent">
<img data-src="https://lh3.googleusercontent.com/ZV1Ise86N6olZqfa-DJCpXDOGSsfvbFlWIQKH4n09GTwjb5onEAcX8i6_ZXEaslGt9aZkB2h5wV5ABVixHb4qLeTsH4nfOXWtnHiDO-w5D3uVT7qtzOEpojXLsfhvFEAKgEb0w8o=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/A3dWKr2UCevpLggI5gFlbkmsdZD2ZjpjuY2hoT9yQak_s3iaAGCiBjzvVP2unQmt5nZ5IKCst7RlbBLkukraxo6xnBgX_gc667oJVMGCEKhc7TSF-zc8xPH8CRDsMrirvWDWMhha=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/Nt94vafT29I_WObrbmS2eHxBD_d0Ug0vMCwOkOWnLZmoq1KttoeZG60Lbs8gcpufcMpTpsEypkR8aAtZV2YpkDMLvXYfANoVZYrp7wAQ2hEKS6uEh6Vww7bExXR2FebPaIGiccFW=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/vdIxO0EVh5NwDRZ8FVpS475JOhWxhrQz6vEtv3XA39LTws5yNRqY3XQgLBGdNRtrl3TE2-rzTdwl5dNjrYd5zmdNBwwIj_eBpnx04bhOZNSc5vDhtpDrBy1s_eUUlx1zFPrSYusT=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/ox8qpKXXhxB3fZvxThrpGND9DuGydWtrPnvy9d4ZqLGX9I7ZcRz7rGJUJ7DNLxRTQzkYBX4JRhso3AY_9wdD7AzGmk-ftH1O-JtrIlmvFONkFRx9ijVtQapxCVm5Ou5oKKia9ULR=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/A7ln8GQksZwkLVJ84MdYK4YLCtzQM6nL1dg_DOrOvWS3IH_AOMH58O8TeTFmr-2-o_FrTLjhihMgu2rTbOnNsAvUWxSti8B7WfJ5376lsZKb3Ej_K49CCpcJoOyYWyocAt9YIiG0=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/CWuI8W_noZd2AMFmkwt-n1wkahbqo-ohHu4mIsqW4L9La2eE48Avbm11LqtLq_jer_RidSCCX8tg4JYbml50gfVBEiNV0hk3dR3UCH1FlydblsdGYlSapzbwUmuKMk_WePmmAWeA=w1920-h1080" src="" alt="" />
 <img data-src="https://lh3.googleusercontent.com/1XGRTj792455ecbQs161P9NvqHYMmbmmkt-dJnM4liv1Beu3MPrQvI29XPIEpvax7Zsexm1Gh9zypdGUX4MsCFn0U9zKQ0NadEkX8748U5Y36PuP0QTCi1FPmuwkRhfko4IIjO1n=w1920-h1080" src="" alt="" />
</div>

However, when i posted it, it's not working.... images are not showing up as tested...

[Image: gj3v7fPThOiRVl_vzmirqSut2CMU_yO-PfV7jR1G...37-h543-no]

Appreciate your kind assistance regarding this issue. 

More power to MyBB!

P.S: any update on Authorization Errors?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)