Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Rejected] Bug editing messages.lang.php in ACP
#1
Hi, I found a strange bug trying to edit just 1 of the language files:

When editing the language variable text in this file:
ACP > Configuration > Languages > English (American) > Front End > messages.lang.php

I get this error upon clicking the "Save" button at the bottom, regardless if I've made a change or not:

"Not Acceptable! An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security."

I don't get the error when editing any of the other language files via ACP (although I only edited a few), AND... I do have the standard .htaccess file uncommented, that is supposed to disable Mod_Security.

I was able to edit the messages.lang.php file directly via my CPanel File Manager > Edit function, but I thought I would report this in case there is a syntax error or something with that file... I even replaced the file with the one from the full install package just in case, but same error, and only with that file.

MyBB version 1.8.20 with PHP v7.1.14
Reply
#2
Try placing the following in your .htaccess

<IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

If that doesn't help contact your hosting support.
[Image: logo.svg.svg]
Reply
#3
I do have that already, and as I mentioned, editing any of the other language files in the list works without a problem... just that single file. And... I've redownloaded and replaced that file from the 1.8.20 full package, rebuilt caches, etc.
Reply
#4
if your web host cannot add relevant white listing rule for it then obviously
the only option could be to edit the file using editor like notepad++ ..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)