Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another image bug in editor
#11
(06-14-2019, 03:27 PM)Devilshakerz Wrote: It's easier for such issues to slip in, given they're not documented as official features that MyBB supports (like drag & drop and pasting images).

Original image URLs, instead of data URIs, would be one of many peculiarities that users may take advantage of in MyBB - some may be unknown to developers, or outright classified as bugs rather than features (similar example: https://github.com/mybb/mybb/issues/3383 - undocumented HTML support in security questions → HTML disabled → something breaks, which gets reported → MyCode support added, addressing main problem).

If you're looking for a quick fix, adding false&& to the
if(yt.FileReader&&s&&kt.test(s[c].type))
condition, which would become
if(false&&yt.FileReader&&s&&kt.test(s[c].type))
in the minified /jscripts/sceditor/jquery.sceditor.bbcode.min.js file may revert this change.


This doesn't solve this bug,just tried it with your solution.
Reply
#12
Thank you so much <3
Reply
#13
Still no quick fix?
Reply
#14
Hello?
Reply
#15
Since I was using the exact plugin (Edit History) that causes MySQL error with this bug and I believe that copying image directly to the editor is common thing in my forum I didn't update and waited for any quick fix. But it's been a month and there's none. Both this bug and MySQL error related to it still exists in community forums aswell:

[Image: mybbsql.png] 
If fixing this 'bug' is not a possibility (since I am not getting answer I take it as it's not) maybe there can be some kind of changes in Edit History plugin that avoids forum having MySQL errors at least?
Reply
#16
(07-15-2019, 02:29 PM)Darkrad Wrote: maybe there can be some kind of changes in Edit History plugin that avoids forum having MySQL errors at least?

Yes, the originaltext column will need its type changed to MEDIUMTEXT / LONGTEXT for MySQL:
ALTER TABLE mybb_edithistory MODIFY `originaltext` LONGTEXT NOT NULL;

It's due to be applied on this board as well.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#17
Is there any solution for this bug?
Reply
#18
I m having the same issue with my forum
now i read this post and still i can not find any solution
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)