Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Verify user - FontAwesome ready
#1
------------------------------------------------------------------------------------------------------------

Lightbulb Latest Version: 1.3 (17.06.2019)


Exclamation Download: https://community.mybb.com/mods.php?acti...w&pid=1270

------------------------------------------------------------------------------------------------------------
  • In the Admin-Control-Panel (ACP) the user's account can be verified under "Account Settings".
  • An icon is then displayed in the Postbit template and member_profile template.
  • You can decide whether you want to display an image or a fontawesome icon.
  • Everything is possible in the settings! You can also choose the size of the image or the icon and the color of the fontawesome icon.
  • You can set the hover text in the settings. This applies to the image and the icon (title="yourText").
  • You can also display the date and/or time next to the image/icon. The date and time refers to the day the user was verified. You can choose between German time (e.g. 13.06.2019 21:33) or English/US time (e.g. 06/13/2019 09:33 PM).
  • You can freely choose the text next to the icon/image and design it as you like using the placeholders {date} and {time}.
  • You can select and set whether the date should be displayed in the profile and postbit.
Info:

1) To verify users edit a user and switch to the tab "Account settings". Below you can set a checkbox.

2) Normally, the plugin automatically inserts the variable into the postbit template to display the icon. If this doesn't work for you (maybe because you have your own individual template/theme),  you can add the following variable to the postbit template:

{$post['icon_vf']}

3) Normally, the plugin automatically inserts the variable into the member_profile template to display the icon + date. If this doesn't work for you (maybe because you have your own individual template/theme), you can add the following variable to the member_profile template:

{$icon_vf}

4) Normally, the plugin automatically edit the headerinclude template to activate/include fontawesome. If this doesn't work for you (maybe because you have your own individual template/theme), you can add the following to the headerinclude template: 

<link href="inc/plugins/css/all.min.css" rel="stylesheet">
Reply
#2
(06-14-2019, 06:22 PM)itsmeJAY Wrote: A user had a plugin request which I implemented with this.

In the Admin-Control-Panel (ACP) the user's account can be verified under "Account -> Settings". An icon is then displayed in the Postbit template and member profile. See screenshots.

I am looking for the screenshots, but I don't see any.
I'm Serpius and You're Not    ¯\_(ツ)_/¯
[Image: 5M7sb0n.png?1]
Reply
#3
Hi,

it is the first screenshot on the plugin page.

(ACP -> User & Groups - SELECT ONE USER - Edit Profile & Settings -  Tab "Account Settings - (scroll down)⁸
Reply
#4
Thanks for this brilliant plugin.

Installed and working fine.
Reply
#5
I suggest to use https://fontawesome.com/icons/check-circ...le=regular instead of current image.
Reply
#6
(06-16-2019, 04:01 PM)ks1001 Wrote: I suggest to use https://fontawesome.com/icons/check-circ...le=regular instead of current image.

I also thought to use some fontawesome icon but i don't know how to use it, are you using it? If yes, can you explain the procedure?

Already tried putting the fontawesome code in the image url.
Reply
#7
This works for me except when deverifying the user, then it throws an SQL error.
Reply
#8
New Version 1.3

+ Escaped language-strings
+ Added fontawesome

Check: https://community.mybb.com/mods.php?acti...0&bid=3965 
+ check attachments

(Yesterday, 05:39 PM)Metallix Wrote: This works for me except when deverifying the user, then it throws an SQL error.

For me it's working fine.. hm! Can you attach a screenshot?


Attached Files Thumbnail(s)
       
Reply
#9
Could just be my forum being weird then..

   
Reply
#10
(Yesterday, 06:13 PM)Metallix Wrote: Could just be my forum being weird then..

Did you installed any plugin called "Sonic Blast" (or something like that). I think the plugin causes the error and may also use the "verified" variable. Did you deactivate the plugin and test it again? Furthermore, the table mybblq_users does not exist at all. Hm!

Someone else has a problem with my plugin? Or is all working fine?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)