[Rejected] MyBB Sceditor Bug
#1
MyBB Sceditor Bug

When try to create a New Thread or Edit and try to see the View Source, the Sceditor Display some Text like:

<p><span id="sceditor-start-marker" class="sceditor-selection sceditor-ignore" style="display: none; line-height: 0;"> </span><span id="sceditor-end-marker" class="sceditor-selection sceditor-ignore" style="display: none; line-height: 0;"> </span><br></p>

Reproduction Steps:

1. Create a New Thread or Edit post.
2. In the Sceditor Press the button View Source
3. It is difficult to write like this in thise mode and it is necessary to see the code of the written
4. Image
[Image: Captura-de-pantalla-2019-06-26-a-la-s-3-45-19-p-m.png]

5. Video:


6. Testing with:
- Opera Versión:60.0.3255.170
- Chrome Versión 71.0.3578.98 (Build oficial) (64 bits)
- Safari browser


Generally when I write I do it in View Source Code and see the BBCode

Any Help to Fix That?  Sad  Sad


Thanks in Advance for the Support!
Reply
#2
Safe to say the editor is being a pain with this update.
Plugin Count: I lost count.
Public Plugins are available here.
Official GitHub.
Please do not PM me for support unless asked to.
Reply
#3
Exclamation 
Another bug:

Requirement: editor in source mode by default.

1º) Click bullet list and see the following code:

[ul]
[li]undefined[/li]
[/ul]

2º) Click numbered list and see the following code:

[ol]
[li]undefined[/li]
[/ol]

I reproduce this error here in the MyBB community forum.

PS: after double-clicking on preview post the correct code is displayed, but with the word undefined.
Reply
#4
(2019-06-26, 11:18 PM)Wires Wrote: Safe to say the editor is being a pain with this update.

Anything can be a pain if instructions not followed properly.
For the problem: apply / reapply MyBB /Default editor style from theme settings.

EHRA for your mentioned issue it is probably trying to consider the single closing brace word as smiley or list item. Need to check further.
Reply
#5
(2019-06-27, 01:46 AM)effone Wrote: Anything can be a pain if instructions not followed properly.
For the problem: apply / reapply MyBB /Default editor style from theme settings.

EHRA for your mentioned issue it is probably trying to consider the single closing brace word as smiley or list item. Need to check further.

For the problem: apply / reapply MyBB / Default editor style from theme settings... 

ok. also test that... Default editor style my Resumen of testing:

Home » Themes » Default

Editor Style:

Office-Toolbar : Same Issue, testing with Opera, Chrome and Safari Browser
[Image: office-toolbar.png]

Defaultdark: See Image Error with Opera and Chrome and Safari Browser Test
[Image: Defaultdark.png]

Office: See image Error with Opera and Chrome and Safari Browser Test
[Image: Office.png]

Modern: See image Error with Opera and Chrome and Safari Browser Test
[Image: Modern.png]

Default: See image Error with Opera and Chrome and Safari Browser Test
[Image: Default.png]

MyBB: See image Error with Opera and Chrome and Safari Browser Test
[Image: MyBB.png]

Squeare: See image Error with Opera and Chrome and Safari Browser Test
[Image: Square.png]


EHRA issue:
PS: after double-clicking on preview post the correct code is displayed, but with the word undefined

I do not understand the error that it describes but maybe its with PReview Post can see the images, check the Preview Code and Thread Code CHanged with Press Botton Preview Post

the [ul] text Change to List [ list]  Check the image of testing EHRA issue I do not understand the error that it describes.
Reply
#6
editor has been a big mess since 1.8.20
Start Your Own Forum With a Trusted , Honest & Powerful Webhost ..TMD HOSTING
Reply
#7
Ok i have the same problem in the past but it was due a some conflive things, if you have a bad upgrade maybe there must be the issue.

1.- You have to go to the upgrade script and run it within the latest mybb version in here, entire package i have not tested the changed files package.

2.- Verify your codebuttons template that must be up to date.

3.- Verify that you have deleted old files from sceditor you can do it by source code aswell.

4.- Verify that you have not a plugins that use editor at all, no one because all of them needs to be updated.

After this steps reviewed you may see that all goes like a charm i have a live environments and localhost even my forum boards are updated and all goes like a charm, maybe there are some lesser issues that i have commented in the past but i think maybe in the next version of mybb will see some of them fixed it.

Anyways you need to review it because this problem is related to the codebuttons old template or the scripts of the old version tryng to work with the new ones, for me the issue was caused by a plugin that i have installed. So you need to review that all is fine in order to get the right values of the new editor due many things have changed.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#8
Didn't mention the last step, @whiteneo. The issue what diogopino is facing is because of the SCEditor is now using Flexbox as the style backbone. He is loading old editor skeleton css.

So, once again, as I have stepped the SCEditor troubleshoot like 1000 times before, I now prefer documenting all steps further:
https://community.mybb.com/thread-223638.html
Reply
#9
- The first thing I write is to sayThanks You for All for Comments, feedbacks and Support!

(2019-06-27, 04:31 AM)Whiteneo Wrote: Ok i have the same problem in the past but it was due a some conflive things, if you have a bad upgrade maybe there must be the issue.

1.- You have to go to the upgrade script and run it within the latest mybb version in here, entire package i have not tested the changed files package.

2.- Verify your codebuttons template that must be up to date.

3.- Verify that you have deleted old files from sceditor you can do it by source code aswell.

4.- Verify that you have not a plugins that use editor at all, no one because all of them needs to be updated.

Anyways you need to review it because this problem is related to the codebuttons old template or the scripts of the old version tryng to work with the new ones, for me the issue was caused by a plugin that i have installed. So you need to review that all is fine in order to get the right values of the new editor due many things have changed.

@Whiteneo that was my test last night... I followed all your recommendations

1. Download FULL Version of MyBB 1.8.21 and Re-Upload All Files System MyBB

2. Yes my codebuttons template, not have changes of templates but in the post of effone the information is different

Default Codebuttons i have on the board mybb 1.8.21
[Image: Captura-de-pantalla-2019-06-27-a-la-s-8-38-53-a-m.png]

Note: The Codebutton its different with post of effone
[Image: Captura-de-pantalla-2019-06-27-a-la-s-9-16-33-a-m.png]

3. Yes, i delete old folder of sceditor and re-upload the new folder sceditor

4. In my Board of MyBB NOT used Plugins, all its default with languaje english and some little performance of icons and index.languaje

effone Wrote:The issue what diogopino is facing is because of the SCEditor is now using Flexbox as the style backbone. He is loading old editor skeleton css.

So, once again, as I have stepped the SCEditor troubleshoot like 1000 times before, I now prefer documenting all steps further:
https://community.mybb.com/thread-223638.html

@effone i am reading your information and testing all  but need some help, What is written in that line?
[Image: Captura-de-pantalla-2019-06-27-a-la-s-8-55-19-a-m.png]
icons: "nonocons" ?
---------
plugins: "undo",
format: "bbcode",
icons: "nonocons", ? not sure What is written in that line?

the rest of lines changes so much, that its my code of codebuttons:
<link rel="stylesheet" href="{$mybb->asset_url}/jscripts/sceditor/editor_themes/{$theme['editortheme']}" type="text/css" media="all" />
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/jquery.sceditor.bbcode.min.js?ver=1821"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/bbcodes_sceditor.js?ver=1821"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/editor_plugins/undo.js?ver=1821"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/sceditor/icons/monocons.js?ver=1821"></script>
<script type="text/javascript">
var partialmode = {$mybb->settings['partialmode']},
opt_editor = {
	plugins: "bbcode,undo",
	style: "{$mybb->asset_url}/jscripts/sceditor/textarea_styles/jquery.sceditor.{$theme['editortheme']}?ver=1821",
	rtl: {$lang->settings['rtl']},
	locale: "mybblang",
	width: "100%",
	enablePasteFiltering: true,
	autoUpdate: true,
	emoticonsEnabled: {$emoticons_enabled},
	emoticons: {
		// Emoticons to be included in the dropdown
		dropdown: {
			{$dropdownsmilies}
		},
		// Emoticons to be included in the more section
		more: {
			{$moresmilies}
		},
		// Emoticons that are not shown in the dropdown but will still be converted. Can be used for things like aliases
		hidden: {
			{$hiddensmilies}
		}
	},
	emoticonsCompat: true,
	toolbar: "{$basic1}{$align}{$font}{$size}{$color}{$removeformat}{$basic2}image,{$email}{$link}|video{$emoticon}|{$list}{$code}quote|maximize,source",
};
{$editor_language}
$(function() {
	$("#{$bind}").sceditor(opt_editor);

	MyBBEditor = $("#{$bind}").sceditor("instance");
	{$sourcemode}
});
</script>


Resumen of Test: I have followed the steps that have recommended me, although I still need to implement the code of Template Codebutton... because I do not understand what written in that line?...
---------
plugins: "undo",
format: "bbcode",
icons: "nonocons", ? not sure What is written in that line?
--------

Now can see the correct BBcode via Quick Edit Button, with Edit Reason
[Image: Captura-de-pantalla-2019-06-27-a-la-s-8-25-10-a-m.png]

in Full Edit Button the same issue:
[Image: Captura-de-pantalla-2019-06-27-a-la-s-8-25-31-a-m.png]
Reply
#10
Its not ur up of tea, sorry to say
Gimme admin access and I'll do these basic things for you (if you can trust)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)