Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved Changing database name and password
#1
Not Solved
If I am changing database name and password, is there anywhere else I need to change it in the script other than inc/config.php? And does it matter what version of MySQL I'm using 5.0 or 5.5?

Thanks
Reply
#2
Not Solved
(07-13-2019, 04:42 PM)caryjoeyork Wrote: If I am changing database name and password, is there anywhere else I need to change it in the script other than inc/config.php?

No.
What goes around comes around
Reply
#3
Not Solved
Thanks. One more thing. I screwed something up trying to upgrade from a 1.6 version. Finally I just uploaded a backed up version of the entire upload folder I had before I started. I also uploaded a backup of the original database. I thought that would take me back to the original board before I started this but now this is what I get when I go to the upload.index.php link to my board.

MyBB Internal Error


MyBB has experienced an internal error and cannot continue.
Error Type:
MyBB Error (41)Error Message:Your board has not yet been installed and configured. Please do so before attempting to browse it.
Please contact the MyBB Group for support.
Reply
#4
Not Solved
Assuming your database is imported correctly, it looks like the details in ./inc/config.php are incorrect
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#5
Not Solved
I have been trying to copy my MyBB forum from one website to another.  I had to change the database name as the DB prefix for both sites was different.  This seems to work ok. 
The only trouble is that when I click on 'Go to the ACP' I end up on the wrong database as it uses the URL of the old site which still exists but I want to get rid of the old site altogether. 

Where can I change this so it goes to the right URL and site?  I have searched in PhpMyAdmin on the new site and changed a few things in the DB but I must be missing something here.

I had changed the bburl field on the database which showed correctly when I went into the ACP settings by typing in the correct URL . I then mucked about until I managed to save or update the settings and now it seems to use the correct URL. Obviously the URL is kept elsewhere than in the DB itself so just changing the DB was not enough.

As a computer programmer of 25 years I find this all a bit stupid - keeping settings in more than one place....
Reply
#6
Not Solved
I never understood why the settings were saved in the database and Inc/settings.php but I figured it was for a good reason. Maybe that can change in 1.9 or 2.0.... fingers crossed.
-Joe
AFreeCloud - Free Cloud-Based Web Hosting!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)