Solved: 1 Year, 8 Months, 2 Weeks ago Go to first unread post/ last post not working on Chrome
#1
Solved: 1 Year, 8 Months, 2 Weeks ago
I'm not sure if this is specific to my custom Theme, hence why posting here (feel free to move Mods)

A member updated to Chrome 76.0.3809.87 and noticed that after doing so when clicking the Go to first unread post (or last post), it now takes them to the first post on the page where the unread post is, not the unread post

I could replicate after updating Chrome, before then it was fine, and still fine on Firefox

And it is very annoying!  However, this isn't happing on MyBB Default Theme, just the Flatty Theme?  Undecided

Any help is appreciated

Actually, to be specific, the page doesn't scroll to the post that is in the link (i.e. #pid123); it simply takes you to the top of the page.

Ok - I found the issue myself.  This is all rather specific to the Theme I use and the edits I have made to that Theme, but posting here should anyone encounter the same issue

No idea why, but after the Chrome update, it doesn't like the inline-block in my CSS for posts and it affects the browsers ability to scroll to the post (why?!).  Replaced with flow-root which has fixed the issue.

.post {
    background: #f9f9f9; 
    display: inline-block;
    margin-bottom: 8px;
    border: 1px solid rgb(136, 78, 160);
}

/* Issue above With inline-block on v76 Chrome - Targeting Chrome and replacing with flow-root */

@media screen and (-webkit-min-device-pixel-ratio:0) {    
    .post {
        display: flow-root;
    }      
}
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)