Jump to the post that solved this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 2 Months ago No date showed in posts
#1
Solved: 2 Months ago
Since the migration to another Host there is no date shown for threads and posts.
Only the time is to see. The seperating comma is visible.

Is there a solution for this?

See attachment.


Ton van Steenoven

www.zbbs.nl/forum (only registered on demand)


Attached Files Thumbnail(s)
   
======
Anton015
Reply
#2
Solved: 2 Months ago
Did you check in the settings if the date format is right?
Reply
#3
Solved: 2 Months ago
Hi,

Admin Control Panel -> Templates (Tab) -> Templates (left column) -> YOUR THEME -> Post Bit Templates > postbit

Check in it if the bold part it's OK:


Quote:<div class="post_content">

<div class="post_head">

{$post['posturl']}

{$post['icon']}

<span class="post_date">{$post['postdate']} <span class="post_edit" id="edited_by_{$post['pid']}">{$post['editedmsg']}</span></span>

{$post['subject_extra']}

</div>

<div class="post_body scaleimages" id="pid_{$post['pid']}">

{$post['message']}

</div>

{$post['attachments']}

{$post['signature']}

<div class="post_meta" id="post_meta_{$post['pid']}">

{$post['iplogged']}

<div class="float_right">

{$post['poststatus']}

</div>

</div>

{$post['input_editreason']}

</div>


If not, paste it here.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#4
Solved: 2 Months ago
And check your translation files (inc/languages/yourlang/global.lang.php) to see if all date values are well translated
[MyBB 1.8 mods] - Offer me a coffee
Do not ask me help through PM
Reply
#5
Solved: 2 Months ago
Code was allright as you wrote it. Must be something else.

It looks weird. The second day after publishing the date appears !!There must be an explanation for this. I think in the part where the date is valuated for publishing or not (The first day the format is in 'hours ago').
Anyone an idea?

================  Is there anyone ho can help me out ?=====================

The problems become worse.
At the old Host the editor gave all HTML code in posts and that seemed to be cured in the new environment (new Host)
A minor problem popped up. No date in post.
A couple of days later the date returned in the way that it started to show after more than 1 day. On the 20st of this month the dates till the 18th are shown (see attachment).
And now the first problem is also back All HTML over the place.


Attached Files Thumbnail(s)
   
======
Anton015
Reply
#6
Solved: 2 Months ago
i am not sure if it is host related, can you list your plugins that you have installed ?
What all changes have you made in your core MyBB files ?
Reply
#7
Solved: 2 Months ago
Hi,

now it's like the problem is with the translation of the word "yesterday" to your language, like Crazycat said:

(08-19-2019, 01:01 PM)Crazycat Wrote: And check your translation files (inc/languages/yourlang/global.lang.php) to see if all date values are well translated

Chek if your language file it's UTF8 encoded, and it's saved without BOM.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#8
Solved: 2 Months ago
(08-20-2019, 11:20 AM)WallBB Wrote: i am not sure if it is host related, can you list your plugins that you have installed ?
What all changes have you made in your core MyBB files ?
Attached to this reply the list of Plugins.

(08-20-2019, 11:37 AM)NoRules Wrote: Hi,

now it's like the problem is with the translation of the word "yesterday" to your language, like Crazycat said:

(08-19-2019, 01:01 PM)Crazycat Wrote: And check your translation files (inc/languages/yourlang/global.lang.php) to see if all date values are well translated

Chek if your language file it's UTF8 encoded, and it's saved without BOM.
I've installed the Fonta Dutch language packet. Latest version is (1.8.12) In the admin part I partly translated its content. Works normal for as I can see.


Attached Files Thumbnail(s)
       
======
Anton015
Reply
#9
Solved: 2 Months ago
Hi,

as Crazycat said, and I guessed, the problem is with the translation file.

Open inc/languages/dutch/global.lang.php (with Notepad++ or similar, to save it without BOM)

Find:
$l['today'] = '<span title="{1}">Vandaag</span>';
$l['yesterday'] = '<span title="{1}">Gisteren</span>';


Replace it with:
$l['today_rel'] = "<span title=\"{1}\">Vandaag</span>";
$l['yesterday_rel'] = "<span title=\"{1}\">Gisteren</span>";
$l['today'] = "Vandaag";
$l['yesterday'] = "Gisteren";

Now it should work.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#10
Solved: 2 Months ago
Correct about the language files. I updated them with the build in AP menu Configuration - Languages - options - (dual languages (EN-NL).

Stays the problem with html tags in the posts.

Thats harder to resolve. Would be nice if anyone can help me out.
======
Anton015
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)