Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 1 Month ago File upload message in 1821.
#1
Solved: 1 Month ago
How do i fix this message when i try to add an attachment file i get this.  "You can upload a maximum of 8.39 bytes at once."   i can not attach any large files and i could before..it all started after i upgraded to 1821 from 1816..this is my personal server i have full control of all setting in "php ini" my upload and file size are good in php.ini.  i am using php7.2. in my php info the 1821 is using local value and not my global value if that helps. 
second question is can i downgrade back to 1816 so i can trouble this.
Reply
#2
Solved: 1 Month ago
(08-27-2019, 08:47 PM)divewiz1 Wrote: How do i fix this message when i try to add an attachment file i get this.  "You can upload a maximum of 8.39 bytes at once."   i can not attach any large files and i could before..it all started after i upgraded to 1821 from 1816..this is my personal server i have full control of all setting in "php ini" my upload and file size are good in php.ini.  i am using php7.2. in my php info the 1821 is using local value and not my global value if that helps. 
second question is can i downgrade back to 1816 so i can trouble this.

It should be MBytes in the string.

Did you going to upload some files bigger than 8Megabytes?

If you're seeing this alert box, your configuration of php_max_upload_size for PHP is not effective for your forum. It should be a server configuration thing, should not be a MyBB problem. However, the unit in the string is probably wrong.
Worth a try.
Reply
#3
Solved: 1 Month ago
I also get this message too now when i add try to add a new post thread.The message is too long. Please enter a message shorter than 65535 characters. This happen also after the upgrade to 1821. 
Did these setting changes come from 1821 upgrade?

I had 1816 set to what i wanted and it work great before i did the upgrade to 21.


(08-28-2019, 08:32 AM)noyle Wrote:
(08-27-2019, 08:47 PM)divewiz1 Wrote: How do i fix this message when i try to add an attachment file i get this.  "You can upload a maximum of 8.39 bytes at once."   i can not attach any large files and i could before..it all started after i upgraded to 1821 from 1816..this is my personal server i have full control of all setting in "php ini" my upload and file size are good in php.ini.  i am using php7.2. in my php info the 1821 is using local value and not my global value if that helps. 
second question is can i downgrade back to 1816 so i can trouble this.

It should be MBytes in the string.

Did you going to upload some files bigger than 8Megabytes?

If you're seeing this alert box, your configuration of php_max_upload_size for PHP is not effective for your forum. It should be a server configuration thing, should not be a MyBB problem. However, the unit in the string is probably wrong.


Thanks for the reply.
That what i though that it was the php setting on my server but every thing check ok. and i double check it..
My server php ini _max_upload_size is set to  999999999M  and it  was working ok before i did the upgrade. that why i was wondering if it was something in the 1821 that did it.
Reply
#4
Solved: 1 Month ago
(08-28-2019, 08:32 AM)divewiz1 Wrote: I also get this message too now when i add try to add a new post thread.The message is too long. Please enter a message shorter than 65535 characters. This happen also after the upgrade to 1821. 
Did these setting changes come from 1821 upgrade?

I had 1816 set to what i wanted and it work great before i did the upgrade to 21.

What's the currently length given by you forum?

The maximum length for a message in post/pm/contact, is either defined by your MyBB configuration settings or limited by the database. See the tip under each aforementioned setting in your AdminCP.

(08-28-2019, 08:32 AM)divewiz1 Wrote: Thanks for the reply.
That what i though that it was the php setting on my server but every thing check ok. and i double check it..
My server php ini _max_upload_size is set to  999999999M  and it  was working ok before i did the upgrade. that why i was wondering if it was something in the 1821 that did it.

Consult https://www.php.net/manual/en/ini.core.php for more, the directives for uploading post size limit (total size in a POST action) is post_max_size and per file uploading file size limit is upload_max_filesize.
Worth a try.
Reply
#5
Solved: 1 Month ago
My copy of 1816 and 1821 both was all ok the whole time.
it was my server, i did an updates a few weeks ago on the php7.2 and apaches2 both from Ubuntu updates that when the trouble started.
somehow that update lock the files sizes and post max both back to local value default and i could not change them no mater what i tried to change them too it would only change the master value.
So I tested everything on a new test server with a fresh install of Linux and lamp with all the new updates and my copy of mybb 1821 and it all work like it should.
all i did was "reinstall Linux and lamp is all" on my original server with my copy of 1821 and a backup copy of SQL back on it and it all working like it should now.
i can now change everything in php.ini file now both local value and master are the same now.
Problem was solved.
Reply
#6
Solved: 1 Month ago
(09-13-2019, 04:50 PM)divewiz1 Wrote: My copy of 1816 and 1821 both was all ok the whole time.
it was my server, i did an updates a few weeks ago on the php7.2 and apaches2 both from Ubuntu updates that when the trouble started.
somehow that update lock the files sizes and post max both back to local value default and i could not change them no mater what i tried to change them too it would only change the master value.
So I tested everything on a new test server with a fresh install of Linux and lamp with all the new updates and my copy of mybb 1821 and it all work like it should.
all i did was "reinstall Linux and lamp is all" on my original server with my copy of 1821 and a backup copy of SQL back on it and it all working like it should now.
i can now change everything in php.ini file now both local value and master are the same now.
Problem was solved.
Glad to see you've solved this problem.

I'm kinda sorry that I forgot to tell you at that moment that some PHP values can be set in the .htaccess file which overrides settings in php.ini. It can also happen when an PHP script has locally set those values, so a clean install of HTTP server & PHP and MyBB will probably solve the problem. Check this https://stackoverflow.com/a/19520881/6681141 .
Worth a try.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)