Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MyAlerts | MyBB has experienced an internal SQL error and cannot continue
#11
I have already tried uninstalling every plugin and leaving only myalerts and the your one active, the problem persists.

So,the conflict is only with these two plugins on my forum.

May be it is because of some server ecc, i have no idea of that.

The problem is:

I activate myalerts,everything ok.

I activate you plugin, everything ok.

Then where your plugin is active, for example in forum number 1, i write a reply and when i click on the post reply button the above error is occured.

And where your plugin isn't active, for example, in forum number 2, i can post without problems and no errors are occured.
Reply
#12
That case maybe it is to outdated plugin version due i have tested with both plugins only in a new entire environment with strict mode and php 7.2 and mybb 1.8.21 but all works fine without any type of issue, maybe it is related to an old code inside a hook that is not taken anymore. But in the last revision all works perfect due i have updated to work with mybb 1.8.21 for all the plugins i write until now, but many of them requires update to last revision if you use mybb 1.8.21 some of them only works on old versions where the values does not change.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#13
Ok, you may be right but the problem is that the old version is working on my some other member's forum as he tested it for me with myalerts and not on my forum.

However, how much will the update cost?
Reply
#14
Since 2017 all those items only have support for the users who have the active membership.

And memberships are only like a donation for all the contents that are inside the forums. But any user cam get it for free as all my developments if they have contributed to the mybb scene with hq contents and constant contributions in here or into my forums. Otherwise it have the cost that is already active into upgrade zone. And that includes active support for all my developments for that period of time only. If another great update came and plugin needs to be update you need to get the membership. That is why if you contribute always you will get it for free always.
The only infinite thing is the universe and human stupidity, but the universe is not for sure

Plugins 1.6.x

Plugins 1.8.x

Reply
#15
May be this can help,in case someone wants to help.

<error>
	<dateline>1572810101</dateline>
	<script></script>
	<line>0</line>
	<type>20</type>
	<friendly_type>MyBB SQL Error</friendly_type>
	<message>SQL Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 1' at line 1
Query: SELECT uid,subject,fid FROM mybbmm_threads WHERE tid =  LIMIT 1</message>
	<back_trace>#0  errorHandler->log_error(20, SQL Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 1' at line 1
Query: SELECT uid,subject,fid FROM mybbmm_threads WHERE tid =  LIMIT 1, , 0) called at [/home/******/public_html/inc/class_error.php:189]
#1  errorHandler->error(20, Array ([error_no] => 1064,[error] => You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'LIMIT 1' at line 1,[query] => SELECT uid,subject,fid FROM mybbmm_threads WHERE tid =  LIMIT 1)) called at [/home/*******/public_html/inc/db_mysqli.php:597]
#2  DB_MySQLi->error(SELECT uid,subject,fid FROM mybbmm_threads WHERE tid =  LIMIT 1) called at [/home/*******/public_html/inc/db_mysqli.php:337]
#3  DB_MySQLi->query(SELECT uid,subject,fid FROM mybbmm_threads WHERE tid =  LIMIT 1) called at [/home/*******/public_html/inc/db_mysqli.php:789]
#4  DB_MySQLi->simple_select(threads, uid,subject,fid, tid = , Array ([limit] => 1)) called at [/home/*******/public_html/inc/plugins/myalerts.php:1100]
#5  myalerts_alert_post_threadauthor(19011) called at [/home/*******/public_html/inc/class_plugins.php:142]
#6  pluginSystem->run_hooks(Array ([function] => myalerts_alert_post_threadauthor,[file] => ), 19011) called at [/home/*******/public_html/inc/datahandlers/post.php:1113]
#7  PostDataHandler->insert_post() called at [/home/*******/public_html/newreply.php:473]
</back_trace>
</error>

Reply
#16
Something is wrong with the query. WHERE tid = _____ LIMIT 1
The condition is incomplete. Something needs to be in the underlined blank space above.

Backtrace 4 shows the first instance of the malformed query. Check myalerts.php, line 1100.

#7 Line 473 in newreply.php version 1821 does not seem capable of generating an error since it is a comment line.
What version of MyBB are you running?

I would find where the function myalerts_alert_post_threadauthor is defined, and where it is called. There is a discrepancy that is creating your malformed query.
Don't do it for me, teach me how to do it myself.
Reply
#17
I'm using the latest version of MyBB with php version 7.0.33
Reply
#18
Is there nobody on forum who can help me here?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)