Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved ACP - Plugins Page Huge Error
#1
Not Solved
I don't really know how to explain this but when I navigate to the Plugins page in the ACP, it seems like its loading the board's settings in text. I have a screenshot of the beginning, but I can't paste the entire thing because it's too long. I've checked the error log and I don't see anything that would indicate an issue, but at this point I'm not sure what I'm looking for.

Screenshot removed!

Help please Sad
Reply
#2
Not Solved
Looks like related to xthreads plugin. Might be some required file is missing...
Try re uploading all the files of that plugin.
[Image: logo.svg.svg]
Reply
#3
Not Solved
Tried that. No change. Tried renaming the plugin php file, no change.
Reply
#4
Not Solved
OP might want to delete the uploaded screenshot file, your credentials are revealed on that image.
Worth a try.
Reply
#5
Not Solved
Try removing the said plugin.
... and take care of what @noyle said.
[Image: logo.svg.svg]
Reply
#6
Not Solved
Both done. It's still doing it. The error starts off like this

#0 errorHandler->log_error(2, require(/home/wlwb/whatlieswebreathe.com/inc/xthreads/xt_admin.php): failed to open stream: No such file or directory, inc/plugins/xthreads.php, 112) called at [/home/wlwb/whatlieswebreathe.com/inc/class_error.php:189] #1 errorHandler->error(2, require(/home/wlwb/whatlieswebreathe.com/inc/xthreads/xt_admin.php): failed to open stream: No such file or directory, inc/plugins/xthreads.php, 1
Reply
#7
Not Solved
This is missing from your server:

require(/home/wlwb/whatlieswebreathe.com/inc/xthreads/xt_admin.php
What goes around comes around
Reply
#8
Not Solved
So I reuploaded the entire xthreads plugin, including that file and this is now how the error starts:

#0 errorHandler->log_error(2, Use of undefined constant XTHREADS_ALLOW_PHP_THREADFIELDS - assumed 'XTHREADS_ALLOW_PHP_THREADFIELDS' (this will throw an Error in a future version of PHP), inc/xthreads/xt_install.php, 8) called at [/home/wlwb/whatlieswebreathe.com/inc/class_error.php:189] #1 errorHandler->error(2, Use of undefined constant XTHREADS_ALLOW_PHP_THREADFIELDS - assumed 'XTHREADS_ALLOW_PHP_THREADFIELDS' (this will throw an Error in a future version of PHP), inc/xthreads/xt_install.php, 8, Array ([_GET] => Array ([module] => config-plugins),[_POST] => Array (),[_COOKIE] => 
Reply
#9
Not Solved
This is a different type of error, a php compatibility one i think.
Are you using the latest available version of Xthreads, and what version of php is your server on ?
What goes around comes around
Reply
#10
Not Solved
Latest available version of xthreads (that I can find) is 1.68, so yes I'm on the latest there. We're on version 7.3.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)