Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not Solved [How To?] Converting MyBB MySQL database from LATIN1 to UTF8
#1
Not Solved
I have a relatively new Forum, with a few hundred threads. I just realized that my hosting provider has a default MySQL character set as latin1. When I take a backup and restore to UTF8, pages are showing incorrect characters. For example, the page https://www.devopsrun.com/t-bash-tree-co...7-centos-8 has
├── anaconda-ks.cfg
and after UTF8 conversion it shows like,
??? anaconda-ks.cfg
I have spent a few hours to find a solution, nothing succeeded so far. I appreciate your suggestions to solve this issue.

I used the below method to convert the DB character set:
iconv -f LATIN1 -t UTF-8 < db.sql > db-utf8.sql
Following all steps given here: http://bdunagan.com/2011/09/29/convertin...1-to-utf8/
Visit our DevOps  Forums | MyBB plugins: Addthis
Reply
#2
Not Solved
Hi,

years ago I had to do it, and I don't remember right now what I did, but I think I've to dump the DB before to replace the characters, like is said here:
http://www.alphadevx.com/a/420-Converting-a-MySQL-database-from-latin1-to-utf8

And have a look at the Special chars won't import correctly part of this:
https://docs.moodle.org/31/en/Converting_your_MySQL_database_to_UTF8
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#3
Not Solved
(11-12-2019, 12:52 PM)NoRules Wrote: Hi,

years ago I had to do it, and I don't remember right now what I did, but I think I've to dump the DB before to replace the characters, like is said here:
http://www.alphadevx.com/a/420-Converting-a-MySQL-database-from-latin1-to-utf8

And have a look at the Special chars won't import correctly part of this:
https://docs.moodle.org/31/en/Converting_your_MySQL_database_to_UTF8
I very much appreciate your time, thank you!
I will try these steps.
Visit our DevOps  Forums | MyBB plugins: Addthis
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)