Not Solved Will not log in need to reload browser to make login "stick"
#1
Not Solved
This issue is since transfer from my old VPS to new VPS server:
Another issue is that if you try to login without checking the box "remember me" nothing happens, it just reverts to the login page as if you never logged in.  Then if you reload the browser page, nothing more than just reloading it, now it shows you logged in.

And then, if you do check the "remember me" box, and login, it won't log you out.  You click to log out and it says you are now logged out, but you remain logged in, until you quit and restart the browser, then finally it shows you as logged in.

This is similar to the issue I was having at a vbulletin 4 forum of mine , which was solved by =
https://forum.vbulletin.com/forum/vbulle...-they-work

I added the
ExpiresActive Off
to the .htaccess inside the /forums directory, and all seems well now at that vb4 forum as far as this login issue.

However, I don't know whether ExpiresActive Off will work with a mybb forum, have not tried yet.


Any ideas?
Reply
#2
Not Solved
(2019-12-05, 07:27 PM)mdawg Wrote: However, I don't know whether ExpiresActive Off will work with a mybb forum, have not tried yet.

Indiscriminate caching with mod_expires would be a likely cause. Dynamic pages shouldn't be cached or served to other users:
https://docs.mybb.com/1.8/administration...on/#server Wrote:If the forum traffic is cached by accelerators or caching servers (e.g. Varnish), you should make sure they are configured properly and never cache the HTML content of MyBB-generated pages, especially those intended for authenticated users, as it may leak secret security tokens intended for individual users or visitors.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#3
Not Solved
I think the over all issue of that can't login without reloading the browser is related to that whenever a new post or any change (delete a post) is made to the forum nothing shows up , no changes appear, until reload browser.

Have not solved this yet.
Reply
#4
Not Solved
Hi,

seems a cache problem as Devilshakerz said. Any URL we could check?
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#5
Not Solved
I added
ExpiresActive Off
to the .htaccess the login/login problem (having to reload browser to make the login or logout "stick") seems to have been solved, but I am still testing the issue of whether the entire page needs to be reloaded to make any change "show."
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)