Not Solved Very slow database query.
#1
Not Solved
Whenever I load a specific subforum on my forum, it takes 1.5 seconds whereas other parts of the forum only take around 100ms. 

This is the query:

[Image: ytoRjws.png]

What could this be?
Reply
#2
Not Solved
Returning north of 220,000 results and then screwing with them might have something to do with it.
Reply
#3
Not Solved
(2019-12-19, 12:18 AM)Ben Cousins Wrote: Returning north of 220,000 results and then screwing with them might have something to do with it.

Sorry, I don't understand what you mean. How did I screw with them?
Reply
#4
Not Solved
If you can access your database through a phpMyAdmin connection, open the connection. Without selecting a database or table, you may see a tab for Status. Observe server stats, then locate the Monitor button, select it and wait for charts to fill. You may see CPU utilization, memory usage or swap memory showing poor performance. These may provide clues to resource usage.

Your query with 220K rows is massively larger than my piddly 13K. If all else is equal, and query timing is a proportional thing, my 55ms query time could scale up to 935ms. Maybe you're not that far off.

You can watch the charts in the monitor screen change in real time performing different operations in the forum.

Performance chart, for example.


Attached Files Thumbnail(s)
       
Reply
#5
Not Solved
Do you have any plugins related to stickies?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)