Not Solved Can't pick editor style after 1.8.21 upgrade
#1
Not Solved
I've already followed the SCEditor fix steps and can post fine on my forum. No real problems with it except minor bugs. 

But when I try to pick an editor style in my themes the menu is blank, there are no options.

Already re-uploaded the SCEditor folder 5 times. Doesn't work. Already reverted codebuttons template multiple times. Doesn't work.

[Image: NTJDPN0.png]
Reply
#2
Not Solved
Does the ACP's Tools & Maintenance → File Verification show any modified/outdated files?
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#3
Not Solved
(2019-12-22, 04:49 PM)Devilshakerz Wrote: Does the ACP's Tools & Maintenance → File Verification show any modified/outdated files?

customlogin/backups/.htaccess	Missing
customlogin/jscripts/codemirror/addon/search/jump-to-line.js	Missing
customlogin/jscripts/codemirror/mode/css/gss.html	Missing
customlogin/jscripts/codemirror/mode/css/gss_test.js	Missing
customlogin/modules/config/report_reasons.php	Missing
customlogin/modules/user/awaiting_activation.php	Missing
inc/plugins/hello.php	Missing


The customlogin thing is just the mybb security measure of changing the admin panel login
Reply
#4
Not Solved
Looks like the theme properties (sorry I can't remember its name) stored in a serialized string in the database goes wrong.

Will OP try to reload this theme, by clicking the "Save Stylesheet Orders"? Though I'm not sure if it'll work.
Could be wrong but worth a try.
Reply
#5
Not Solved
(2019-12-22, 06:01 PM)noyle Wrote: Looks like the theme properties (sorry I can't remember its name) stored in a serialized string in the database goes wrong.

Will OP try to reload this theme, by clicking the "Save Stylesheet Orders"? Though I'm not sure if it'll work.

Could very well be the case since my forum is from 2015 and has a lot of posts and has been through a lot of orange. 

I tried it but didn't work.

Can anyone help me?
Reply
#6
Not Solved
still havent been able to fix.

(2019-12-22, 06:01 PM)noyle Wrote: Looks like the theme properties (sorry I can't remember its name) stored in a serialized string in the database goes wrong.

Will OP try to reload this theme, by clicking the "Save Stylesheet Orders"? Though I'm not sure if it'll work.

Upon closer look when I press "Save Stylesheet Orders" as you mentioned I get the following error page very briefly before it goes back to the settings:

[Image: vBGNmHx.png]

inc/functions_themes.php seems to be completely missing..

However when I check release notes for 1.8.21 it says functions_themes.php was "changed"

However checking the files for a clean download 1.8.21 it's not there either.

Am I going insane?
Reply
#7
Not Solved
Check the file at path ./admin/inc/functions_themes.php: https://github.com/mybb/mybb/blob/mybb_1...themes.php

Make sure you have correct 1.8.21 files for your MyBB forum.
Could be wrong but worth a try.
Reply
#8
Not Solved
(2019-12-24, 08:55 AM)noyle Wrote: Check the file at path ./admin/inc/functions_themes.php: https://github.com/mybb/mybb/blob/mybb_1...themes.php

Make sure you have correct 1.8.21 files for your MyBB forum.

I've replaced it. I'm pretty sure I'm dealing with a faulty 1.8.21 upgrade at this point. Will test with upgrading again but last time it wrecked my forum.

You know what? eggplant MyBB. I'm so tired of this extremely glitchy forum software that breaks on every update. I can't deal with this orange anymore. Bought a Xenforo license and will be migrating. I'm OUT.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)