[Pushed] Nested lists not working properly
#1
Hello,

When composing a post containing nested lists, an extra <ul> is added on each switching between text editor and SCEditor.

For example this code :
To Do:
[list]
[*]Fix the boiler
[*]Buy:
[list]
[*]Eggs
[*]Milk
[/list][*]Call mother
[/list]

is rendered as :
To Do:
  • Fix the boiler
  • Buy:
    • Eggs
    • Milk
  • Call mother
As you can see, an extra line is added before "Eggs", and every switching between text/rich editor adds an extra line at the beginning of each nested list.

This behaviour was the same with 1.8.21.. and earlier I think.

The use of nested \[list\] mycodes is really very inconvenient! (and this for a long time)

Edit : I edited my post and now there are two blank lines before "Eggs"...
Reply
#2
I was getting this yesterday. I thought it was something I was doing. Thanks for bringing it up. It's very annoying.
Reply
#3
To Do:
  • Fix the boiler
  • Buy:
    • Eggs
    • Milk
  • Call mother

(2019-12-31, 05:42 PM)spyto Wrote: (...)
is rendered as :
To Do:
[list]
[*]Fix the boiler
[*]Buy:
[list]
[*]

[*]Eggs
[*]Milk
[/list][*]Call mother
[/list]
(...)

Do you use the source editor or the WYSIWYG editor?

OK, you mean unwanted additional lines/<li> is added upon switching between source editor and WYSIWYG editor.

Yes, switching between them does result in some unexpected behavior..
Could be wrong but worth a try.
Reply
#4
I use the text editor and I switch to the Wisywyg editor.

But using only the text editor then posting gives the same result, an extra line is added.

Each switching between the two editors adds a new extra line... infinitely...
I think is impossible to create nested lists in the WYSYWYG editor! Huh



Edit : I think the problem exists since v1.8.20. SCEditor.

Using ckeditor has not been successful, to say the least.
Reply
#5
Use Rin editor instead Smile
[MyBB 1.8 Czech translation] [MyBB 1.8 plugins]: Prune old PMs + optimize DB plugin --- Thank you/like system
Reply
#6
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/4074

Thanks for contributing to MyBB!

Regards,
The MyBB Group
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)