Not Solved [Mail] Forum isn't sending activation or email reset emails.
#1
Not Solved
Forum isn't sending activation or email reset emails.

MYBB 1.8.22
http://pheeds.com/phorum

Using PHP email OK - tested php emails from host using this script
https://docs.mybb.com/1.8/faq/mail/

Mass email sent and received - also verified php email is working.

Checked email logs - no errors shown

Admin, Return and Contact email settings all use *@domain.com.

Registered Users appear in Users Awaiting Activation

This install has a number of plugins activated, but I have a second MYBB test install on the same domain/host with zero plugins or changes to templates and minimal Admin settings changes and email doesn't work on it either.
Reply
#2
Not Solved
Hello,
any errors in MyBB's error log? (In $MYBBROOT/error.log by default)
Reply
#3
Not Solved
I don't see an issue?

[03-Jan-2020 05:37:08 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[04-Jan-2020 21:38:39 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[05-Jan-2020 05:07:40 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[07-Jan-2020 23:53:38 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[09-Jan-2020 00:07:05 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[11-Jan-2020 05:39:37 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[11-Jan-2020 15:52:59 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[11-Jan-2020 15:53:00 UTC] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
Reply
#4
Not Solved
Also, email subscription notice when someone replies to a post works. So it isn't server/php related and MYBB is sending email in some circumstances.

So far, email works EXCEPT for:
Email verification registration
Password recovery email.

There may be other email issues but I haven't found any yet.

These two seem to be connected in some way? Does anyone have any ideas please? Thanks.
Reply
#5
Not Solved
did you see your spam emails?
[Image: banner.gif]
Reply
#6
Not Solved
(2020-01-15, 04:42 PM)Mastersly Wrote: did you see your spam emails?
Of course of I did, as well as white listing the forum email address in my own accounts. There have been over a dozen different users on different email accounts as well as me testing on a number of my own accounts and no email receive.

Edit added later: If it was a spam issue the other emails wouldn't be getting through.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)