Rating problems in Dark Mode
#1
I have three themes for my members to choose from. Dark Mode 1.8 has issues with ratings. On Chrome and Firefox it locks up for me whenever I try to give a rating. A member on Opera and Firefox has a different issue. The scrollbar disappears whenever he tries to give a rating. I had issues with ratings before I did any changes to 1.8.
My site: https://theprosestylist.net
Ratings are very important to my members. They want to give points to every post. I tried to DL My Reactions and wasn't able to get the last file to DL. It just sat at 0% for ages. I tried another 'like' plug in but the instructions weren't written for a novice like me. I'll try another one.
Thank you for your time and suggestions.
Wink
Reply
#2
Hi,

there's a problem in the headerinlcude template of your Dark Theme.

It tries to load the file jquery-ui.js from the folder images/dark1.8/, and it's not there.

Try to fix it (to the right path where the file is) and the problem will go away.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#3
(2020-01-12, 05:14 PM)NoRules Wrote: Hi,

there's a problem in the headerinlcude template of your Dark Theme.

It tries to load the file jquery-ui.js from the folder images/dark1.8/, and it's not there.

Try to fix it (to the right path where the file is) and the problem will go away.

Thank you for that information.

I found this in the header include

<script src="images/dark1.8/jquery-ui.js"></script>

So I need to change . . . the "images/dark/1.8/" part of that to where the jquery-ui.js file is? Or the file isn't there and I need to do something else? Is there another way of finding the jquery-ui.js file than just looking at every template?

My apologies, I'm very new to this.

Thank you for your time.

My site: https://theprosestylist.net
Reply
#4
Hi,

maybe the file it's there, but I can't find it, so you have to replace this line:
<script src="images/dark1.8/jquery-ui.js"></script>

with:
<script src="https://code.jquery.com/ui/1.11.1/jquery-ui.min.js" integrity="sha256-4JY5MVcEmAVSuS6q4h9mrwCm6KNx91f3awsSQgwu0qc=" crossorigin="anonymous"></script>
(Same version as your original Theme)
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#5
(2020-01-13, 09:14 AM)NoRules Wrote: Hi,

maybe the file it's there, but I can't find it, so you have to replace this line:
<script src="images/dark1.8/jquery-ui.js"></script>

with:
<script src="https://code.jquery.com/ui/1.11.1/jquery-ui.min.js" integrity="sha256-4JY5MVcEmAVSuS6q4h9mrwCm6KNx91f3awsSQgwu0qc=" crossorigin="anonymous"></script>
(Same version as your original Theme)

Thank you again, but it didn't work. I replaced the code with the other one, saved it, did a hard refresh, checked it on two browsers, and still the same issue.

I appreciated your time and patience.
Reply
#6
Hi,

now we're facing a "date" problem. The theme last update was in 2014, and at this time MyBB was using jQuery v1.11.1. Now your forum is using jQuery v3.3.1 and maybe it's the problem.

Try first to replace this line in the headerinlcude template of your Dark Theme:
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/jquery.js?ver=1800"></script>


With:
<script src="https://code.jquery.com/jquery-1.11.1.min.js" integrity="sha256-VAvG3sHdS5LqTT+5A/aeq/bZGa/Uj04xKxY8KM/w9EE=" crossorigin="anonymous"></script>


Now the BIG BUT (Sir Mix-a-Lot pun intended):
Your theme is really old and it's not updated, so it could have security flaws, you must be warned.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)