Jump to the post that solved this thread.
Solved: 5 Months, 3 Weeks, 2 Days ago Jquery not defined
#1
Solved: 5 Months, 3 Weeks, 2 Days ago
Hi all!

since I changed provider, I crashed into the "jquery not defined" thing, so Javascript does not work anymore. I don't see postbuttons in post editor, neither I can rename threads on the fly, nor anything else that needs JS.
After reading this thread I decided to open my own, because what's described there does not work for my domain.

Using MyBB since 2006 and running last version now (1.8.22) but never encountered a situation like this so any help is appreciated.  Smile

From what I know, I can provide some details:
- after changing to new provider JS has worked previously, but I doubt, if I imported the old board with deactivated plugins
- I think, after resetting templates, something has blocked JS functionality
- I don't have started all plugins again, so there might be one or another with "active" flag in the database (?), but I took the opportunity not to upload all plugins again, because some became useless with the time

URL is in my profile.

best regards!
Reply
#2
Solved: 5 Months, 3 Weeks, 2 Days ago
can you switch to MyBB's Stock theme and check if the error persists ..
Reply
#3
Solved: 5 Months, 3 Weeks, 2 Days ago
Hi,

there's a problem with your jquery.js  file, it's like it's corrupted and some lines are not ok:
https://www.diffchecker.com/7oKyIvTe

Try to reupload the file in your jscripts folder from MyBB's last version and check again.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#4
Solved: 5 Months, 3 Weeks, 2 Days ago
That was a great help, thanks @NoRules.

I found out, not only jquery.js was ANSI-coded on my server, some other js-files were affected too. Reason unknown, but now solved with reuploaded UTF8-coded files. Once I checked the byte sizes these days, it would never come in my mind to check codings in files because they were identical. Don't have made a version upgrade either because there was version 1.8.22 on the old server already running.

JS is working fine now, problem solved. Big thanks again!

cheers  Smile
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)