Jump to the post that solved this thread.
Solved: 1 Year, 6 Months, 2 Weeks ago Prev. forum version
#1
Solved: 1 Year, 6 Months, 2 Weeks ago
Upgrade is asking for previous version. But I have copied the new files in place so I cant start the forum and check. Can I see the ver. no. some where?
Reply
#2
Solved: 1 Year, 6 Months, 2 Weeks ago
The upgrade script should be able to identify the forum's version of data stored in the database by the version_history entry in table mybb_datacache. Anyway, the versionentry in table mybb_datacache stores the human readable version and version code information.

If you still have your old files, you may also find the version in file ./inc/class_core.php.
Could be wrong but worth a try.
Reply
#3
Solved: 1 Year, 6 Months, 2 Weeks ago
Perfect! Great info!
Reply
#4
Solved: 1 Year, 6 Months, 2 Weeks ago
I think the upgrade detects the version itself and it is displayed as the selected item in the dropdown form input. Wasn't this the case for you? I might be wrong.
Reply
#5
Solved: 1 Year, 6 Months, 2 Weeks ago
Im almost positive I did last time I upgraded (a long time ago) but not here.
Reply
#6
Solved: 1 Year, 6 Months, 2 Weeks ago
I tried upgrading another forum and got the drop down box and it suggested 1.8.15 but my old version was 1.16.11...

So checking according to noyle might be a good idea :-)
Reply
#7
Solved: 1 Year, 6 Months, 2 Weeks ago
(2020-03-05, 06:34 PM)RigPa Wrote: I tried upgrading another forum and got the drop down box and it suggested 1.8.15 but my old version was 1.16.11...

So checking according to noyle might be a good idea :-)
AFAIK, the upgrade script reads version information from the same data field in the same table in your database. If it doesn't suggest the correct version to which it'll upgrade to, there might be inconsistency in your data, though I'm not very sure.
Could be wrong but worth a try.
Reply
#8
Solved: 1 Year, 6 Months, 2 Weeks ago
If It might be an indicator that something isn't working as expected but I won't worry myself too much over it.

The script might have some conditionals to consider which version to display as selected (if any), for example.
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)