Not Solved Members can't change passwords
#1
Not Solved
Does anyone else get a ton of contact emails from members asking for help changing passwords?  They all say that they try 2 or 3 times but the new password never works!  I did some testing and I did receive the reset email promptly but I discovered that the first link in the reset email doesn't work at all...when you click on it, you get this error:

This page isn’t working
www.7173mustangs.com is currently unable to handle this request.
HTTP ERROR 500


The 2nd link in the reset email does open the password reset screen on my forum, but I entered my username and the password reset code from the email and I get this message:

You seem to have entered an invalid password reset code. Please re-read the email you were sent or contact the forum administrators for more help

So, what could the problem be and how can I fix it?  I am tired of resetting passwords every day, LOL!
MyBB 1.8.22 (x4)
7173Mustangs.com, pa2a.org, pazrt.com & paguntalk.com
Reply
#2
Not Solved
have you checked server error log to trace the cause of internal server error ?

for the invalid password reset code :
are you using any plugins related to passwords (hash - etc)

have a look at few search results
Reply
#3
Not Solved
(2020-03-18, 01:23 AM).m. Wrote: have you checked server error log to trace the cause of internal server error ?

for the invalid password reset code :
are you using any plugins related to passwords (hash - etc)

have a look at few search results

I don't see any errors in the log and I am not using any plugins that affect passwords...this issue does appear to affect all 3 of my fourums but 7173mustangs is the busiest and hass the most user complaints.

I have read through all the other threads on MyBB.com and it really points to an issue with MyBB that hasn't ever been pinned down.
MyBB 1.8.22 (x4)
7173Mustangs.com, pa2a.org, pazrt.com & paguntalk.com
Reply
#4
Not Solved
Hi,

this is more complicated as it shows at first instance. I've created a new user to test it.

In the mail you have this link:
https://www.7173mustangs.com/member.php?action=resetpassword&uid=8353&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ

But if you click it it changes to:
https://www.7173mustangs.com/user-eleveeeeee?action=resetpassword&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ
And 500 error.

If you copy/paste first URL o try the second way to reset it, then a 404 error happens:
Failed to load resource: the server responded with a status of 404 (Not Found)
https://www.7173mustangs.com/user-eleveeeeee?action=resetpassword&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ

I think the server it's trying to load a file that not exists "user-eleveeeeee" because of an .htaccess rule that changes "member.php&uid=8353" to "user-eleveeeeee". It should be a "member.php" file

Seems to me (maybe I'm wrong) that an .htaccess rule is creating all this (or more than one).
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#5
Not Solved
(2020-03-30, 05:50 PM)NoRules Wrote: Hi,

this is more complicated as it shows at first instance. I've created a new user to test it.

In the mail you have this link:
https://www.7173mustangs.com/member.php?action=resetpassword&uid=8353&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ

But if you click it it changes to:
https://www.7173mustangs.com/user-eleveeeeee?action=resetpassword&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ
And 500 error.

If you copy/paste first URL o try the second way to reset it, then a 404 error happens:
Failed to load resource: the server responded with a status of 404 (Not Found)
https://www.7173mustangs.com/user-eleveeeeee?action=resetpassword&code=ORo8JO6WdDPGbMJ5xktJM9TdaWNpTJ

I think the server it's trying to load a file that not exists "user-eleveeeeee" because of an .htaccess rule that changes "member.php&uid=8353" to "user-eleveeeeee". It should be a "member.php" file

Seems to me (maybe I'm wrong) that an .htaccess rule is creating all this (or more than one).
Interesting!  Would do I need to look for in order to fix it?
MyBB 1.8.22 (x4)
7173Mustangs.com, pa2a.org, pazrt.com & paguntalk.com
Reply
#6
Not Solved
Hi,

I would check your .htaccess  file and comment the line that maybe it's creating the problem:
RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

Change it to:
# RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

Remember to use Notepad++ or similar to edit the file, and save it Without BOM.

Now test if everything works as intended.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#7
Not Solved
(2020-03-31, 07:00 PM)NoRules Wrote: Hi,

I would check your .htaccess  file and comment the line that maybe it's creating the problem:
RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

Change it to:
# RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

Remember to use Notepad++ or similar to edit the file, and save it Without BOM.

Now test if everything works as intended.
I don't have the above line in my .htaccess file at all.  I do have this one that is close:

RewriteRule ^User-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]
I tried commenting that line out and tested password reset but it still doesn't work.
MyBB 1.8.22 (x4)
7173Mustangs.com, pa2a.org, pazrt.com & paguntalk.com
Reply
#8
Not Solved
Hi,

oops! my fault Blush , the line it's OK, don't comment it.

Try to deactivate Google Seo plugin and check if it works now.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#9
Not Solved
(2020-04-01, 11:16 AM)NoRules Wrote: Hi,

oops! my fault Blush , the line it's OK, don't comment it.

Try to deactivate Google Seo plugin and check if it works now.
Deactivated Google SEQ and tested...still got the same results: Error 500 and invalid reset code.
MyBB 1.8.22 (x4)
7173Mustangs.com, pa2a.org, pazrt.com & paguntalk.com
Reply
#10
Not Solved
Hi,

I need to have a look to the content of your .htaccess file. Paste here, or if you want to keep it private, PM it to me.
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)