Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Quick Reply form won't show posted message
#1
Bug 
So, here is the problem.
I write message in Quick Reply field in thread, and when I click "Submit" I get that spinner image that is loading short period of time, and than it's gone. Until that point everything is good, but my message isn't displayed. I need to refresh page in order to see my message.
This is happening only in Linear thread mode.

URL of my forum: https://kombat.rs
Test account (You can login even if forum is closed):
Username: test 
Password: mybb123

EDIT: I tried to revert showthread_quickreply to original and it's still doesn't work.
EDIT2 I figure it out why this is happening. It's because of showthread template.  But I didn't managed to fix it yet.
(I know this because when I reverted this template to original it worked)

Template:

<html>
<head>
<title>{$thread['subject']}</title>
{$headerinclude}
<script type="text/javascript">
<!--
var quickdelete_confirm = "{$lang->quickdelete_confirm}";
var quickrestore_confirm = "{$lang->quickrestore_confirm}";
var allowEditReason = "{$mybb->settings['alloweditreason']}";
lang.save_changes = "{$lang->save_changes}";
lang.cancel_edit = "{$lang->cancel_edit}";
lang.quick_edit_update_error = "{$lang->quick_edit_update_error}";
lang.quick_reply_post_error = "{$lang->quick_reply_post_error}";
lang.quick_delete_error = "{$lang->quick_delete_error}";
lang.quick_delete_success = "{$lang->quick_delete_success}";
lang.quick_delete_thread_success = "{$lang->quick_delete_thread_success}";
lang.quick_restore_error = "{$lang->quick_restore_error}";
lang.quick_restore_success = "{$lang->quick_restore_success}";
lang.editreason = "{$lang->postbit_editreason}";
lang.post_deleted_error = "{$lang->post_deleted_error}";
lang.softdelete_thread = "{$lang->soft_delete_thread}";
lang.restore_thread = "{$lang->restore_thread}";
// -->
</script>
<!-- jeditable (jquery) -->
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/report.js?ver=1804"></script>
<script src="{$mybb->asset_url}/jscripts/jeditable/jeditable.min.js"></script>
<script type="text/javascript" src="{$mybb->asset_url}/jscripts/thread.js?ver=1813"></script>
</head>
<body>
{$header}
{$threadnotesbox}
{$pollbox}

<div id="konu_bilgi_cubugu">
<div class="konu_avatar">
<i class="fas fa-comment-dots fa-4x"></i>
</div>
<div class="konu_baslik"><h1>{$thread['threadprefix']} {$thread['subject']}</h1><p>posted by {$thread['username']}</p></div>
<div class="konu_istatistik">
<dl><dt><i class="far fa-eye fa-fw" title="Views"></i></dt><dd>{$thread['views']}</dd></dl>
<dl><dt><i class="far fa-comment fa-fw" title="Replies"></i></dt><dd>{$thread['replies']}</dd></dl>
{$ratethread}
</div>
</div>

<div class="sayfaLinkGrubu">
<div class="float_left"> 
{$multipage}
</div>
<div class="LinkGrubu">
{$newreply}
<a href="javascript:void(0)" id="thread_modes">Topic Mode</a>
<a href="javascript:void(0)" id="thread_tools">Thread Tools</a>
</div>
</div>

<div id="post">
{$posts}
</div>

<br class="clear" />
{$quickreply}
{$threadexbox}
{$similarthreads}
<br />



<div class="float_right" style="text-align: right;">
{$moderationoptions}
{$forumjump}
</div>
<br class="clear" />
{$usersbrowsing}
{$footer}

<div id="thread_tools_popup" class="popup_menu" style="display: none;">
{$printthread}
{$sendthread}
{$addremovesubscription}
{$addpoll}
</div>

<div id="thread_modes_popup" class="popup_menu" style="display: none;"><div class="popup_item_container"><a href="showthread.php?mode=linear&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->linear}</a></div><div class="popup_item_container"><a href="showthread.php?mode=threaded&amp;tid={$tid}&amp;pid={$pid}#pid{$pid}" class="popup_item">{$lang->threaded}</a></div></div> 

<script type="text/javascript">
// <!--
if(use_xmlhttprequest == "1")
{
$("#thread_modes").popupMenu();
}
// -->
</script>
<script type="text/javascript">
// <!--
if(use_xmlhttprequest == "1")
{
$("#thread_tools").popupMenu();
}
// -->
</script>
<script type="text/javascript">

var thread_deleted = "{$thread_deleted}";
if(thread_deleted == "1")
{
$("#quick_reply_form, .new_reply_button, .thread_tools, .inline_rating").hide();
$("#moderator_options_selector option.option_mirage").attr("disabled","disabled");
}
</script>
</body>
</html>
iAndrew & NickGHQ - Respect!!
Reply
#2
have you checked quickreply issue by switching to MyBB's Stock theme ?

have you tried it by temporarily disabling the plugins ?
forum admin panel >> configuration [settings] >> general configuration >> Disable All Plugins
Reply
#3
(03-23-2020, 01:54 PM).m. Wrote: have you checked quickreply issue by switching to MyBB's Stock theme ?

have you tried it by temporarily disabling the plugins ?
forum admin panel >> configuration [settings] >> general configuration >> Disable All Plugins

Yes, I forgot to say that.
It works in MyBB's Stock theme, and I looked qoucikreply template there, most of the code looks the same like in my template and I am not sure what to add/change so I posted this thread.
Also, tested with disabled plugins, and the issue is stil there.
I tried to add
onsubmit="MyFunctuion()" 

and in MyFunction:
location.reload(); 


but that didn't worked at all.
iAndrew & NickGHQ - Respect!!
Reply
#4
would you like to PM me temporary access to forum admin panel to check the issue ...
[you may have to wait for my free time - I can check later today or tomorrow]
Reply
#5
Sounds like an issue with your postbit templates. The element containing your postbit is probably lacking the correct ID. The quick reply function relies on the following to display the post after you submit it:
id="post_{$post['pid']}"

Make sure the element containing your postbit has that. (postbit templates > postbit and postbit_classic)

While we're at it, make sure it also has this:
style="{$post_visibility}"
Reply
#6
This is fixed now thanks to the NickGHQ 
His is awesome, he came to my forum, registered and fixed issue in less than 2 minutes Big Grin
Anyway, the issue was that I had to replace <div id="post"> with <div id="posts"> in showthread template.
iAndrew & NickGHQ - Respect!!
Reply
#7
^ good to know it Smile somehow I overlooked your posted code !
Reply
#8
Personally I solved this issue with copying code from postbit_classic template to postbit
and then rewrite it to look similarly to postbit (because I like its look much more), but using div-s from postbit_classic,
after this it's working OK for me (it show new post after sending it via quick reply).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)