Not Solved convert ipb 4.3.6 to mybb error
#11
Not Solved
Yes.

[Image: ipb2.png]
Reply
#12
Not Solved
(2020-04-11, 09:00 AM)dimi1967 Wrote: Yes.

[Image: ipb2.png]

Please review line #51 where message_posts should be core_message_posts.

message_posts is the table name for private messages in IPB 3, while in IPB 4 the table name for private messages is core_message_posts. Sorry I've made a mistake in the first response post, please make changes according to this post: https://community.mybb.com/thread-227220...pid1347000
Could be wrong but worth a try.
Email me at: [email protected]
Reply
#13
Not Solved
It doesn't work, I'm disappointed.....

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1366 - Incorrect string value: '\xCF\x8C\xCF\x81\xCE\xBF...' for column dwsgjekm_mybb.mybb_privatemessages.message at row 1
Query:
INSERT INTO mybb_privatemessages
Reply
#14
Not Solved
(2020-04-11, 08:37 PM)dimi1967 Wrote: It doesn't work, I'm disappointed.....

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1366 - Incorrect string value: '\xCF\x8C\xCF\x81\xCE\xBF...' for column dwsgjekm_mybb.mybb_privatemessages.message at row 1
Query:
INSERT INTO mybb_privatemessages

Weird.

Did you turn Encode to UTF-8 (Automatically convert messages to UTF8?: Turn this off if the conversion creates weird characters in your forum's messages.) on?

What's the character encoding of the source table core_message_posts?

If you need further (remote) assistance, could you please PM me or find me in MyBB's Discord server (noyle is my nickname)?
Could be wrong but worth a try.
Email me at: [email protected]
Reply
#15
Not Solved
Yes it is in utf8

[Image: core.png]
Reply
#16
Not Solved
Please help solve the problem? Sorry I don't know English and I can't ask for help via pm
Reply
#17
Not Solved
(2020-04-15, 10:38 AM)dimi1967 Wrote: Please help solve the problem? Sorry I don't know English and I can't ask for help via pm

Could you please post the file content of `/boards/ipb4/privatemessages.php just like in https://community.mybb.com/thread-227220...pid1347069 once more?

If you've properly modified that file and based on details you've provided and the result, I don't know where the problem is right now. A person-to-person help might help and hope anyone else could shed light on this issue as well.
Could be wrong but worth a try.
Email me at: [email protected]
Reply
#18
Not Solved
Thanks go ahead! now I have one last error ..Attachments

Warning [2] finfo_file(monthly_12_2012/post-167-143604228901.jpg): failed to open stream: No such file or directory - Line: 69 - File: merge/boards/ipb4/attachments.php PHP 7.3.16 (Linux)
Reply
#19
Not Solved
(2020-04-15, 02:56 PM)dimi1967 Wrote: Thanks go ahead! now I have one last error ..Attachments

Warning [2] finfo_file(monthly_12_2012/post-167-143604228901.jpg): failed to open stream: No such file or directory - Line: 69 - File: merge/boards/ipb4/attachments.php PHP 7.3.16 (Linux)

Attachment importing is the most mystery part during merge.

If you can confirm the reported file exists and is readable, you could:
  • Try importing attachments using different Uploads Path. For example, use direct local path, relative or absolute ones are OK, or setup an HTTP server to serve the attachment and then use the URL as Uploads Path.
  • For either way, you should make sure the merge script has read permissions via the Uploads Path you entered so that it could read each attachment.
Could be wrong but worth a try.
Email me at: [email protected]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)