Solved: 1 Year, 1 Month, 3 Weeks ago Hiddent content error because of thank you plugin
#1
Solved: 1 Year, 1 Month, 3 Weeks ago
When a user tried to unlock an hidden content for 2 points he get the following message
[Image: xTmEhqE.png]

When you go back to the thread the content is unlocked,
Does anyone know how to fix this?
[Image: banner.gif]
Reply
#2
Solved: 1 Year, 1 Month, 3 Weeks ago
Please link us to the plugin you are using.
Reply
#3
Solved: 1 Year, 1 Month, 3 Weeks ago
Manually recreate the column. I had this happening to me as well and I fixed it by recreating the column.
Reply
#4
Solved: 1 Year, 1 Month, 3 Weeks ago
Omar G I am using these two plugins
https://community.mybb.com/thread-169382.html
https://forums.mybb-plugins.com/Thread-H...tent-1-4-2

Alexander L. Idont know how to do that bro
[Image: banner.gif]
Reply
#5
Solved: 1 Year, 1 Month, 3 Weeks ago
(2020-05-29, 12:53 PM)Mastersly Wrote: Omar G I am using these two plugins
https://community.mybb.com/thread-169382.html
https://forums.mybb-plugins.com/Thread-H...tent-1-4-2

Alexander L. Idont know how to do that bro

https://www.pair.com/support/kb/adding-a...hpmyadmin/
Reply
#6
Solved: 1 Year, 1 Month, 3 Weeks ago
It looks to me that the "Hide Content" plugin is trying to integrate nicely with the Thank-You/Like System (TYL) plugin, except that several versions ago, we (the developers of the TYL plugin) dropped from the threads table the tyl_tnumtyls column that the "Hide Content" plugin is trying to update. We dropped it because it was literally not being used anywhere in our plugin other than having its contents updated - they were never meaningfully read/displayed. We hadn't, though, considered that other plugins might be using it.

If what this looks like to me is in fact what is the case, then probably the developer of the "Hide Content" plugin should be informed so he can drop references to the tyl_tnumtyls column. On the other hand, if that plugin (and potentially others) have a valid use for that column, then we ought to add it back in to the TYL plugin. Does anybody know whether the "Hide Content" plugin is doing anything useful with that now-dropped column?
Reply
#7
Solved: 1 Year, 1 Month, 3 Weeks ago
Than you for you reply everyone,
I am noob in databases and dont want to make any changes there by myself.
Alexander L. I checked you link but I dont understand it since is my first time into phpmyadmin dababases.

A tutorial would help me because I dont know in which database table should I add a column to.

I dont even understand this
https://www.pair.com/support/kb/wp-conte...olumns.png
https://www.pair.com/support/kb/wp-conte...olumns.png

What should I add there? The same number and location?
[Image: banner.gif]
Reply
#8
Solved: 1 Year, 1 Month, 3 Weeks ago
Mastersly, it should be enough for you to select your MyBB database and then run this query on it:

ALTER TABLE mybb_threads ADD tyl_tnumtyls int(100) NOT NULL default '0';

If you have selected a table prefix other than "mybb_", then you will need to substitute it there.

This query should be safe to run. To undo it (although I don't know why you'd want to), you could run this query (again substituting for the "mybb_" prefix as necessary):

ALTER TABLE mybb_threads DROP column tyl_tnumtyls;

The only caveat I'd warn about is that if the data in this column is being used in a meaningful way by the Hide Content plugin, then simply creating it will not be sufficient: its value will default to zero rather than to whatever it should be - but I haven't paid for the Hide Content plugin and so don't have access to its code and can't investigate to see whether or not it is using this column's data in a meaningful way. Sorry about that.
Reply
#9
Solved: 1 Year, 1 Month, 3 Weeks ago
Okay I run that query on mybb database
and I got this error when i try to unlock a thread with points
https://i.imgur.com/SQiN293.png

Ohh sorry, When I tried to unlock a thread it works but when I click like button and then unlock a thread I get that error
[Image: banner.gif]
Reply
#10
Solved: 1 Year, 1 Month, 3 Weeks ago
If the error is occurring on "unlock", which I understand to be a feature of the Hide Content plugin rather than the TYL plugin, then, since I don't have access to the Hide Content plugin's code, I have reached the limit of my ability to help you. I am sorry. I can only suggest that you bring this problem up with that plugin's author. I would be happy to collaborate with him in resolving this problem if/as necessary.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)