Solved: 2 Years, 3 Weeks ago SSL -error 403/404 [solved]
#1
Solved: 2 Years, 3 Weeks ago
Hello. Firstable im using google seo on forum.
After turn on let's encrypt ssl i had a padlock on chrome but i couldn't enter site because of gettin 403 error or 404. 
I changed in general settings every http:// to https:// 

My .httaccess:

RewriteEngine on
 
# Some hosts require RewriteBase to make RewriteRules work.
RewriteBase /

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ https://www.meskieforum.pl/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^temat\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Nowości\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^Użytkownik\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Kalendarz\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Wydarzenie\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

<IfModule mod_rewrite.c>
RewriteCond %{IS_SUBREQ} false
RewriteRule ^index.php$ https://www.meskieforum.pl [R=301,L]
</IfModule>

I don't know what am i doing wrong. I need help. Also i installed DVZ secure content.
Reply
#2
Solved: 2 Years, 3 Weeks ago
Hi,

your SSL certificate it's incorrect, it's for:
microhost.pl

and not for your URL. Fix it and check again.

If you access the URL without the https, it works as intended:
http://www.meskieforum.pl/
I don't answer questions about localhost forums or forums without URL, I'm not a seer.  Cool
Reply
#3
Solved: 2 Years, 3 Weeks ago
Sure now it's works because i turned ssl off. Wink
I didn't want to leave the forum with errors for more than a few hours.
I'll bring it back soon.

Ok i turned it on. Ive got 403 on main site...

I had to check "Use a symbolic link from private_html to public_html " in my host settings to make things works. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)