Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: 1 Week, 4 Days ago "Failed to start TSL Encryption" mail error.
#1
Solved: 1 Week, 4 Days ago
Greetings,

Until this issue, I've been able to solve my problems using google and the vast resources at mybb, but for this, I need more help so I created an account. I'm willing to pay for services in solving my problem. It's a strange issue and although I've found similar cases here, I'm not sure how to apply them to my issue.

I'm using MyBB 1.8.22 and am on PHP 7.4.7. I am on shared hosting.


Long story short, In order to address my MyBB forum emails going to spam, I started using a 3rd Party SMTP provider called "sendinblue." It has worked perfectly up until about a week and a half ago and the MyBB emails are no longer being dispatched. The email error log says,


"Failed to start TLS encryption" with "SMTP Server Response: 220".

I haven't changed any settings or anything else at all to cause that error, so I assumed it was on SendinBlue's end, and opened a ticket with them. They told me to try disabling encryption and try again. When I did that, the following error occurred,

"The SMTP server rejected the supplied SMTP password. Reason: 535 Incorrect authentication data."

I responded to them with that error, but haven't heard back yet. Again, I haven't changed anything, so I'm not sure why it would have an authentication error after removing encryption. But, I double checked MyBB email settings and it is set up correctly per sendinblue's SMTP service. I turned encryption back on for now just to get the board back to where is was originally

Please note, I'm also running a Wordpress site on the same server with the exact same settings from sendinblue and it's working just fine.

Off to google I went to search for "MyBB failed to start TSL encryption" and I came across the thread below, and particularly the last post. It seems that anyone with this problem ultimately finds their way to this post which indicates that perhaps it's a server side issue, but not being an expert in what they're saying, I'm not sure what to try with that information. 

https://community.mybb.com/thread-209319...68737.html

Any ideas with why MyBB would suddenly start having errors, while on the same server, Wordpress is working just fine? Do I need to try to do something as described in the thread above?


Thank you so much for your time.


Justin

Just an update, I tried google's SMTP service using TSL and port 587 and the same set of circumstances occurred. First, with encryption enabled, the failed to start TSL encryption error, then with encryption disabled, the rejected password error.

Update 3, I figured out how to run the script noted in the thread cited above. This is the error that it gives,


Error: stream_socket_enable_crypto(): Peer certificate CN=delta.gcwebhosting.com' did not match expected CN=smtp-relay.sendinblue.com'




I opened a ticket with my host. Is there anything that I can do to resolve it?

Host solved this. I'm not sure what changed when it "broke," but everything is working now. He said,

"Hi,

Error: stream_socket_enable_crypto(): Peer certificate CN=delta.gcwebhosting.com' did not match expected CN=smtp-relay.sendinblue.com'
This is a certificate mismatch from your script, it is expecting smtp-relay.sendinblue.com, not our CN.

I have removed some SMPT restrictions for your account. Lets see if that works."
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)