Solved: 1 Year ago error after upgrade PHP version
#1
Solved: 1 Year ago
Hello all.

I have a problem in my forum, after upgrade my version PHP, I have some problems in the plugins.
I try to resolve some, but one of the resist.

"Warning [2] Use of undefined constant CKEDITOR_PLUGINROOT - assumed 'CKEDITOR_PLUGINROOT' (this will throw an Error in a future version of PHP) - Line: 17 - File: inc/plugins/ckeditor.php PHP 7.3.19 (Linux)"
Any help to fix?

I try unninstall and disable, but not working
Begincaos
[email protected]@@---

[Image: assinatura.jpg]
Reply
#2
Solved: 1 Year ago
This should be posted in the Plugins Support forum: https://community.mybb.com/forum-72.html

However, looks like that plugin version hasn't been made compatible with PHP 7.3. A code change will be required in that plugin.

Please verify line 17 of inc/plugins/ckeditor.php
define(CKEDITOR_PLUGINROOT,MYBB_ROOT.'inc/plugins/ckeditor/');

If you do not have this code, please make sure you have the latest version installed https://community.mybb.com/mods.php?acti...oad&pid=73
[Image: modmybb-banner-0.png]
If you think I've helped you; a + rep would be appreciated.
Reply
#3
Solved: 1 Year ago
(2020-07-19, 03:33 PM)KevinVR Wrote: This should be posted in the Plugins Support forum: https://community.mybb.com/forum-72.html

However, looks like that plugin version hasn't been made compatible with PHP 7.3. A code change will be required in that plugin.

Please verify line 17 of inc/plugins/ckeditor.php
define(CKEDITOR_PLUGINROOT,MYBB_ROOT.'inc/plugins/ckeditor/');

If you do not have this code, please make sure you have the latest version installed https://community.mybb.com/mods.php?acti...oad&pid=73

Sory, I tought is a problem of the forum, not from plugin, because I uninstall and dont work.
I see the file you say and have the code you mention.
there is the problem more detailled
Warning [2] Use of undefined constant CKEDITOR_PLUGINROOT - assumed 'CKEDITOR_PLUGINROOT' (this will throw an Error in a future version of PHP) - Line: 17 - File: inc/plugins/ckeditor.php PHP 7.3.20 (Linux)
File 	Line 	Function
/inc/plugins/ckeditor.php 	17 	errorHandler->error
/admin/modules/config/plugins.php 	516 	require_once
/admin/index.php 	824 	require
Begincaos
[email protected]@@---

[Image: assinatura.jpg]
Reply
#4
Solved: 1 Year ago
(2020-07-19, 09:22 PM)begincaos Wrote:
(2020-07-19, 03:33 PM)KevinVR Wrote: This should be posted in the Plugins Support forum: https://community.mybb.com/forum-72.html
I see
However, looks like that plugin version hasn't been made compatible with PHP 7.3. A code change will be required in that plugin.

Please verify line 17 of inc/plugins/ckeditor.php
define(CKEDITOR_PLUGINROOT,MYBB_ROOT.'inc/plugins/ckeditor/');

If you do not have this code, please make sure you have the latest version installed https://community.mybb.com/mods.php?acti...oad&pid=73

Sory, I tought is a problem of the forum, not from plugin, because I uninstall and dont work.
I see the file you say and have the code you mention.
there is the problem more detailled
Warning [2] Use of undefined constant CKEDITOR_PLUGINROOT - assumed 'CKEDITOR_PLUGINROOT' (this will throw an Error in a future version of PHP) - Line: 17 - File: inc/plugins/ckeditor.php PHP 7.3.20 (Linux)
File 	Line 	Function
/inc/plugins/ckeditor.php 	17 	errorHandler->error
/admin/modules/config/plugins.php 	516 	require_once
/admin/index.php 	824 	require

I see! The issue is definitely from a plugin.

Replace inc/plugins/ckeditor.php line 17 with the following contents

BEFORE:
define(CKEDITOR_PLUGINROOT,MYBB_ROOT.'inc/plugins/ckeditor/');

AFTER:
define('CKEDITOR_PLUGINROOT',MYBB_ROOT.'inc/plugins/ckeditor/');

That should do the trick.
[Image: modmybb-banner-0.png]
If you think I've helped you; a + rep would be appreciated.
Reply
#5
Solved: 1 Year ago
Work like a charm. many thanks
Begincaos
[email protected]@@---

[Image: assinatura.jpg]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)