Not Solved Plugin Uploader
#1
Not Solved
I would like to know if that plugins work good with the last version of mybb and If is possible to Use A Set Password For All time And Not For cookie Because my Browser Dont have Cookie Saved and is not possible .. i find just to put a password like a Pin For Admin panel .. ?

https://community.mybb.com/mods.php?action=view&pid=821

i want to try it but i cannot for the moment and Like you know probably already i have installed and re installed the forum a lot of time and this is why before try i am ask ..
Reply
#2
Not Solved
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1071 - Specified key was too long; max key length is 1000 bytes
Query:
CREATE TABLE 2323426625544343233223_pluginuploader ( pid SMALLINT(5) NOT NULL AUTO_INCREMENT PRIMARY KEY , name VARCHAR(255) NOT NULL UNIQUE KEY, version VARCHAR(25) NOT NULL , files TEXT NOT NULL ) ENGINE = MYISAM ;


My prefix is the number of you see (example).. and i have that message error when i try to Go in admin panel (plugin) after i have Activated the Uploader plugin .. I can deleted in /inc/plugins/pluginsuploader.php .. for re have acess to my Plugin section but Why i have that error ?

I want to advice i dont think is that but my admin Directory are not the default ... the prefix is number and not mybb_




the plugins i have take the plugin on mybb but there is the Github link i have found is 10 second ..

https://github.com/MattRogowski/Plugin-Uploader


i use Nginx and is same to use apache is maybe not The problems ?

* Plugin Uploader 1.2.2

* Copyright 2017 Matthew Rogowski

* Licensed under the Apache License, Version 2.0 (the "License");
* you may not use this file except in compliance with the License.
* You may obtain a copy of the License at

** http://www.apache.org/licenses/LICENSE-2.0
Reply
#3
Not Solved
^ in the plugin file you can try changing (line #64)
`name` VARCHAR(255) NOT NULL UNIQUE KEY
to
`name` VARCHAR(100) NOT NULL UNIQUE KEY
Reply
#4
Not Solved
Problem Solved Thanks youuuuuu Big Grin is working i have the plugins instaled
[/quote]

i have that error

There was an error importing this plugin. The following files could not be moved to their proper locations:

./inc/plugins/antifloodsecurity.php

You can either try importing the plugin again, or uploading these files manually.


Any have recommendation i have try 90 % of all of my plugins + 15 and no one Working Is made error Cannot import to location .. The plugins are downloaded for the most Here in mybb community ... I think The plugin uploader is working with old Plugin 1.6 And when he have re Updated for 1.8 he have not check for See if is working realy.. Because i am on a Fresh install of ubuntu and mybb and With the plugin in .zip ...

or is for apache only or obligated to use ftp
Reply
#5
Not Solved
(2020-07-27, 01:48 AM)malcom5322 Wrote: Problem Solved Thanks youuuuuu Big Grin is working i have the plugins instaled

i have that error

There was an error importing this plugin. The following files could not be moved to their proper locations:

./inc/plugins/antifloodsecurity.php

You can either try importing the plugin again, or uploading these files manually.


Any have recommendation i have try 90 % of all of my plugins + 15 and no one Working Is made error Cannot import to location .. The plugins are downloaded for the most Here in mybb community ... I think The plugin uploader is working with old Plugin 1.6 And when he have re Updated for 1.8 he have not check for See if is working realy.. Because i am on a Fresh install of ubuntu and mybb and With the plugin in .zip ...

or is for apache only or obligated to use ftp

My suggestion is quit using this plugin for now and upload the files using FTP.
The plugin was last updated in 2017 and there is possible chance that apart from the edits suggest by .m, you may need more core edits in the plugin.
Reply
#6
Not Solved
Noticed the plugin was quite old, but thought I'd butt out - lol.

In a number of threads, OP seems be messing with a local install.  So guessing doesn't use ftp.  But leveraging plugins to get around existing limitations isn't a good plan IMO.  Eventually, you want to get into a hosting environment.  Then understanding ftp, tar, permissions, and many other basic things will pay dividends.  Taking shortcuts and searching for work-arounds will hurt in the end.  And doesn't assist others looking for help in real world situations much either. Rolleyes

cheers....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)