AdminCP login difference desktop v. mobile
Continuing down the rabbit hole of securing my site.

Running myBB 1.8.23 with adminCP requiring PIN and 2FA. 
Runs flawless on Windows 10 desktop via Chrome and Edge.

When attempting to login to adminCP via Chrome on Android as well as Chrome and Safari via iPad, I am getting a popup form for USERNAME and PASSWORD instead of the web page input like on the desktop. I enter the correct USERNAME and PASSWORD, but it is rejected on everything except the desktop.

I turned off 2FA and PIN , no change
I cleared cookies, no change
I tried different browsers, no change
I tried multiple platforms (Android and iPad), no change.
I enabled DESKTOP SITE in Chrome, no change.

I'm not running a mobile version of myBB.

Do I have a configuration issue here or is accessing adminCP from a mobile browser not an option?

Thanks so much.

EDIT: I've tried this on the default theme as well as others just in case it was a theme issue but no change.

Screenshot attached.
MyBB uses a web page form for ACP login, regardless of used devices - the prompt may be a result of custom configuration ( or plugins. (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪
Man oh man where the hell you we about 18 hours ago?  Big Grin

I pretty much secured myself out of my site using that guide. Turns out you are correct, it was the basic auth that was asking for credentials, not my ACP. It never even crossed my mind so I have been diving down the rabbit hole with .M trying to figure out why my cookies are screwed up. Anyway, I'm all straightened out now. Thanks for the helpful direction.

Forum Jump:

Users browsing this thread: 1 Guest(s)