Not Solved Error 1064 for 'Updating Database' in upgrade
#1
Not Solved
I receive this error when attempting to upgrade my forum installation:

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups TEXT NOT NULL' at line 1
Query:
    ALTER TABLE mybbg0_attachtypes ADD groups TEXT NOT NULL 

I'm trying to upgrade from 1.8.7. I first tried updating to 1.8.11, which produced the error. I tried again (on a restored installation) with 1.8.8 and the error still occurs. Unfortunately, it doesn't tell me the source of the problem - just that it's at line 1.

Before attempting to upgrade, I deactivated all plugins, as well as enabled the 'disable plugins' option.

Any ideas how I can try to troubleshoot this? Huh
Reply
#2
Not Solved
Try updating using the Full Package of the latest MyBB version.

Full Package upgrade goes through all consecutive version changes, and bugs in old upgrades may be fixed in new versions.

For reference: this issue is related to a 1.8.7 → 1.8.8 upgrade and the root cause was fixed in 1.8.18 (https://github.com/mybb/mybb/issues/2921).
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)