Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[For 1.8] Link Tools 1.3.2
#21
Thanks Omar for the feedback.
Reply
#22
I installed it in localhost and activated it. But how does it work? I am not seeing anything on my existing links !!
Reply
#23
You need to first index your links, aka "extract" them from your posts, which you can do from the Link Tools entry in the ACP Plugins page (it should be warning you that not all links have yet been extracted), or alternatively directly from the ACP's Tools & Maintenance => Recount & Rebuild page using the Rebuild Link Tables For Link Tools entry. Then you should run Repopulate Terminating Redirects For Link Tools, also accessible from those same pages. This is a "two for the price of one" process in that it both determines the terminating link for all extracted links (after all redirects have been resolved) as well as generates link previews and caches them (because while we're querying web servers to determine terminating links, and thus have access to the contents of the pages at those links, we might as well build the previews for them).

Once those two tasks have run, you should start to see previews in existing posts, and can, if you like, change the plugin's "On-the-fly link preview (re)generation domains" setting from "No domains" to "All domains".

I'd have to revisit the code to be sure, but I suspect that a shortcut for all of that to start viewing links immediately without going through the recount&rebuild tasks is to change that on-the-fly setting up-front - the only problem with that even if I'm correct though is that because none of the previews would be cached, your thread pages with links will be slow to load the first time as the web servers for the links are queried to build the link previews.

Just one other note: even without doing any of that, link previews should anyway be generated for any links you include in new posts (if they're not, then please let me know - that's a bug).

Phew, I hope that's not all too confusing. Any further questions, please just ask!
Reply
#24
Did all these three 'Recount & Rebuild'..Still nothing..

[Image: Capture.png]
Reply
#25
Hmm. That's odd. Can you run a query something like this on your database, and tell me what the result is? (Substitute your forum prefix for mybb_ if that's not it):

select count(*) from mybb_url_previews;

Also, could you tell me whether you're seeing a fourth "Recount & Rebuild" entry, "Rebuild Link Previews for Link Tools"? If you're not (which seems to be the case based on the rounded left-bottom corner below the third entry), then you might have an outdated version of the plugin.
Reply
#26
I checked the database. I found mybb_urls but no mybb_url_previews.

Although I could be wrong since I know nothing about coding and certainly have no experience in running SQL queries.

Anyway,

[Image: Capture.png]
Reply
#27
Then it seems that my suggestion (edited in by a later post) above might perhaps be correct: "you might have an outdated version of the plugin."

Could you please make sure that you have installed version 1.1.0 of the plugin? Otherwise, I am at something of a loss. The mybb_url_previews table is installed by that version of the plugin. This is very odd!
Reply
#28
Yup only three option present in Recount and Rebuild no "...Preview..."...

I am seeing the version is 1.0.1

Now you must be wondering how I ended up downloading an older version. The reason is that in mybb extension page it is still the older version..

[Image: Capture.png]

So, downloaded the version 1.1.0 from github and installed it. After recount & rebuild. It did showed this.

[Image: Capture.png]

As, you can see there is a 'Regenerate Preview' option available.  So, I clicked it after logging in. And it showed this.

[Image: Capture2.png]

But nothing changed still showing the previous default image..

Regarding your previous query. I checked in my database & yes now "mybb_url_previews" is present now.
Reply
#29
(2021-02-22, 01:02 PM)vk_knight Wrote: Now you must be wondering how I ended up downloading an older version. The reason is that in mybb extension page it is still the older version..

I see that now. I expect that it is because, out of caution, I marked 1.1.0 as a "Development" release. I didn't expect it to have the effect of limiting its distribution. I am sorry about that. It seems though that I cannot change it now that it's been uploaded.

(2021-02-22, 01:02 PM)vk_knight Wrote: So, downloaded the version 1.1.0 from github and installed it. After recount & rebuild. It did showed this.

[Image: Capture.png]

OK. That would be expected for a link which is, perhaps, a 404, or which otherwise does not return useful information.

(2021-02-22, 01:02 PM)vk_knight Wrote: As, you can see there is a 'Regenerate Preview' option available.  So, I clicked it after logging in. And it showed this.

[Image: Capture2.png]

But nothing changed still showing the previous default image..

Mmm, that is potentially worrying, but it really does depend on what the link actually is. Can you please share that?

(2021-02-22, 01:02 PM)vk_knight Wrote: Regarding your previous query. I checked in my database & yes now "mybb_url_previews" is present now.

OK, super, thanks, that's what I would expect now that you've managed to download the (sadly hidden) most recent version of the plugin.

P.S. I would have responded ASAP but for some reason didn't get notification of your response by email, and only (finally) found it by manually checking this thread. I will have a little nurse on a caffeinated beverage so as to (hopefully) stay awake long enough to resolve this problem with you.
Reply
#30
The link is live and well.. If that what you are asking.. It's a simple webpage of wordpress.

Ohhh man !!! You don't have to work that much hard for me... Sad

Get some rest. It can be fixed tomorrow..  Wink
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)