Not Solved Merge from phpbb 3.2.0 to 1.8.24 not transvering forums, treads and posts correctly.
#1
Not Solved
Old forum: phpBB 3.2.0
PHP: 7.1.33
SQL ENGINE: MySQLi 5.0.12

Current MyBB: 1.8.24
PHP: 7.4.3
SQL ENGINE: MySQLi 8.0.22

Fresh install: YES

Merge: 1.8.23

Problem: 
  • Forums are being imported but don't have the correct parent info, when all is imported its simply a big mess of different forums not in order or parented to anything. 
       
  • Treads are being imported but no further info is being added, no fid, prefix, icon, poll, uid, username, dateline, firstpost, lastpost, lastposter, lastposteruid, views, replies, closed, sticky, numratings, totalratings, notes, visible (always 1), unapprovedposts, deletedposts, attachmentcount, deletetime, import_tid, import_uid, import_poll, import_firstpost. 
    All values are 0. subject does have tread title. 
       
  • mybb_posts stays empty, no errors given during import process. 
Sub-problem:
  • mybb_polls not getting correct pid and tid, question, options and votes are being filled but rest has a "0" value. 
       
  • mybb_pollvotes only data for vid rest is "0" 
       
I've used merge in the past without a problem but that was in March I think.

I have been trouble shooting for a good day now but can't find any info on the problem, could it be a MySQL setting from the old or new location or php related? Because there is no info/error I have absolutely no clue what's going wrong. 
I did look in to the merge code and that seems to be good to me.
Reply
#2
Not Solved
Would you mind sharing an example SQL dump, with forums and some of threads/posts/polls/pollvotes, of your phpBB database in the private forum? https://community.mybb.com/forum-135.html
Could be wrong but worth a try.
Reply
#3
Not Solved
I can do that, let me collect the files and I'll create a post in the private forum!
Reply
#4
Not Solved
Thanks! I'll take a look later.
Could be wrong but worth a try.
Reply
#5
Not Solved
Hi guys, this is the same problem happening on Vanilla. I reported the issues of import here https://github.com/mybb/merge-system/issues/264 I also sent a copy of the SQL to import to Euan as instructed. Thank you.
Reply
#6
Not Solved
OP's problem was due to MySQL 8.0.19's deprecation on integer width. An GitHub issue is tracking it https://github.com/mybb/mybb/issues/4166...-730332679 . We'll try to work out a fix as soon as possible.

(2020-12-05, 12:35 PM)luisalvarado Wrote: Hi guys, this is the same problem happening on Vanilla. I reported the issues of import here https://github.com/mybb/merge-system/issues/264 I also sent a copy of the SQL to import to Euan as instructed. Thank you.

Euan will probably take a look at the Vanilla db dump in this weekend.
Could be wrong but worth a try.
Reply
#7
Not Solved
Hi guys, is there anything I can do here since we have very few days before we get trapped with Vanilla for a full year again.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)