Jump to the post that solved this thread.
Not Solved [Performance] Mybb Php 8.0
#1
Not Solved
Mybb when will it support php 8.0? Huh

Thanks
Reply
#2
Not Solved
MyBB will support PHP 8.0 in upcoming versions (1.8). Work has begun on it but we can't guarantee or promise a set version. Hopefully next release.
Reply
#3
Not Solved
Still doesn't work with MyBB 1.8.27.
Peace,
Gene Steinberg
Co-Author
Attack of the Rockoids
Reply
#4
Not Solved
(2021-06-23, 03:15 PM)Gene Steinberg Wrote: Still doesn't work with MyBB 1.8.27.

Won't happen. 1.8 is done they are putting all effort into 1.9 now.
Reply
#5
Not Solved
Whilst we did fix some php 8 issues in 1.8.27 it is likely you may still face issues.

If you are attempting to use PHP 8 on the 1.8.27 it would be helpful for any error messages to be reported in the bugs forum for us to consider.
-Ben

Please do not PM me for support. I am looking to be hired for paid services.

You can view my paid services here.
Reply
#6
Not Solved
Please report any PHP 8 issue you find in 1.8.27

We already know it is possible not all issues were fixed, so that detail alone won't help much.
Reply
#7
Not Solved
(2021-06-23, 07:37 PM)Omar G. Wrote: Please report any PHP 8 issue you find in 1.8.27

We already know it is possible not all issues were fixed, so that detail alone won't help much.

So do we report errors here or not .. the above confused me a bit Huh
Not in this land alone,
But be God's mercies known,
From shore to shore!
Lord make the nations see,
That men should brothers be,
And form one family,
The wide world ov'er

Reply
#8
Not Solved
Yes, if there are any PHP errors/warnings/notices on the page or the error log, you can post them here.
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#9
Not Solved
(2021-06-27, 02:54 PM)Devilshakerz Wrote: Yes, if there are any PHP errors/warnings/notices on the page or the error log, you can post them here.

Ok
from digging around a bit, I don't think the cache system is working correctly as certain variables are not made available to the processing script

an example 

[Image: DH4773p.png]

Plugins :- some plugins are using curly braces ($myarray{0}) to access array offsets this causes the admin cp to just error out with a 500 http error, disabling plugins at least gets the admin cp running again 

running the admin cp index.php gives the following errors 

[Image: WNQs8LO.png]

does this indicate that the $mybb object is not being created ?


Attached Files
.txt   error.txt (Size: 103.96 KB / Downloads: 13)
Not in this land alone,
But be God's mercies known,
From shore to shore!
Lord make the nations see,
That men should brothers be,
And form one family,
The wide world ov'er

Reply
#10
Not Solved
Were all the attached errors generated when running 1.8.27? Some of them suggest outdated (or modified) files.

Added some things to investigate in https://github.com/mybb/mybb/issues/4138...-872245095

(2021-07-01, 07:47 AM)JimR Wrote: running the admin cp index.php gives the following errors 

[Image: WNQs8LO.png]

does this indicate that the $mybb object is not being created ?

If the file was executed through CLI, that may be normal.

<error>
	<script>showthread.php(1612) : eval()'d code</script>
	<line>46</line>
	<type>2</type>
	<friendly_type>Warning</friendly_type>
	<message>Undefined property: MyLanguage::$thread_modes</message>
	<back_trace>#0  errorHandler->error() called at [/showthread.php(1612) : eval()'d code:46]
#1  eval() called at [/showthread.php:1612]
</back_trace>
</error>

This language string was removed in https://github.com/mybb/mybb/pull/4351/files (template needs to be updated)
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)