Not Solved Version 1.8.24 Doesn't work on PHP 8.0
#1
Not Solved
I upgraded to PHP 8.0 from PHP 7.0 and it broke my MyBB installation. So then I rolled back to PHP 7.3 (because I've heard PHP 7.4 deprecates some stuff) and it worked.
[Image: Np4WW4v.png]
RuneScape Community
My forums, powered by MyBB, of course. ;-)
Reply
#2
Not Solved
That's kinda interesting for developers and early adopters of PHP8!

Just to prevent other users from running into such troubles, did you record any PHP errors or made notes for publication and further investigations?
Guess a lot of guys here will benefit of your experience and looking forward to any more details.

[ExiTuS]
New Forum / MyBB 1.8.24 + innovative full-responsive Theme
Live-Escape-Game-Forum
Reply
#3
Not Solved
If I recall, 8.0 is going to require 1.8.25 (a developer will know more information than I will on this).

I will say that 7.4 seems to be pretty stable at the moment. I'm having absolutely no issues whatsoever, running two forums both with a great deal of plugins. I initially had worries about compatibility as well (phpBB breaks on 7.4 but works on 7.3), but MyBB seems to be pretty safe on 7.4 for the time being, at least from my end.
Reply
#4
Not Solved
See https://github.com/mybb/mybb/issues/4138 - MyBB 1.8 is expected to receive compatibility patches for PHP 8.0, and the progress on the remaining element will dictate which version will be fully compatible (at current state, the Admin CP on 1.8.25 may be free of errors).

There are no known issues related to running PHP 7.4.

Version recommendations are posted, and updated, here: https://docs.mybb.com/1.8/install/requirements/
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#5
Not Solved
(2021-01-30, 07:59 PM)W13 Wrote: I upgraded to PHP 8.0 from PHP 7.0 and it broke my MyBB installation. So then I rolled back to PHP 7.3 (because I've heard PHP 7.4 deprecates some stuff) and it worked.

I feel ya as I had the same issue recently on a localhost with 8 presenting the white screen of death on install attempt..., and yes as you stated rolling back to 7 reverted the issue as 8.0 is not currently yet supported as folks have already stated.

just for example even bitnami mybb stack sticks with 7.3.26

ie:

Updated
11 days ago

Version
1.8.24

Version 1.8.24-4      2021-01-21
* Maintenance release
* Updated Apache to 2.4.46
* Updated lego to 4.1.3
* Updated MyBB to 1.8.24
* Updated MySQL to 8.0.22
* Updated OpenSSL to 1.1.1i
* Updated PHP to 7.3.26
* Updated phpMyAdmin to 5.0.4
* Updated SQLite to 3.34.0

and while yes thier mamp and wamp stacks at 7.4.x work fine with mybb, 8 will not yet as mybb does not yet fully support 8 Wink
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)