Jump to the post that solved this thread.
Not Solved New php version 7.4 and errors have appeared
#1
Not Solved
Hi there,

the php for my forum has just been updated (not by me. Seemingly there has been a change of server), but now the forum is broken as I get some errors and I cannot even access the admin panel. What can I do?
I am not sure of the image posted is going to work. This is the link anyway:
https://www.dropbox.com/s/q84a1ekvp25t4t...8.png?dl=0
[Image: Screen%20Shot%202021-03-08%20at%2016.35.36.png?dl=0]
Reply
#2
Not Solved
What MyBB version are you on?

Edit: can see from your signature it's 1.8.21... it's a plugin that's erroring, so you'll need to see if there's a newer version of the plugin, or contact the plugin author.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#3
Not Solved
So, there is an incompatibility between PHP and the plugin?
The problem is that I cannot access the admin panel, so I am stuck. Do I need to ask to downgrade to the old version of PHP?
Reply
#4
Not Solved
It seems so yes. For the time being you can just rename the ./inc/plugins/myadvertisments.php file to something else and it won't be loaded, or upload a newer version of the plugin in its place (if there is one). No need to fully downgrade PHP really.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#5
Not Solved
(2021-03-08, 05:30 PM)Matt Wrote: It seems so yes. For the time being you can just rename the ./inc/plugins/myadvertisments.php file to something else and it won't be loaded, or upload a newer version of the plugin in its place (if there is one). No need to fully downgrade PHP really.
Thanks Matt.
I have tried to contact the author of the plugin, in the meantime I'll do as you suggest (although I am still waiting for the new fto credentials).

Well, those who host the forum have edited the plugin changing "continue" with "break" (or viceversa) and now I can access it again. !
Reply
#6
Not Solved
These errors base on a syntax change in PHP version from 7.2 to any higher level.

For a quick resolution, you can edit your myadvertisement.php file and replace all "continue" by "break" within each switch statement.
This could fix the issues for the moment
(until the developer serves an updated and fully-reviewed version).

[ExiTuS]
MyBB Forum + innovative full-responsive Theme
Live-Escape-Game-Forum
Reply
Jump to the post that solved this thread.


Forum Jump:


Users browsing this thread: 1 Guest(s)