Forum security
#1
Hi all,

Sorry if the question doesn't make sense. I'm working on my forum and getting ready to launch to the public.

One of the things I'm concern about is the security and was wondering if I install Powerful Firewall plugin, would this be enough to protect the forum from hackers? 

Any thoughts will be very useful. Thank you so much.
Reply
#2
Be surprised if such an old plugin worked properly with current versions of mybb - not that I've tried.  And you need to be current with mybb, php, and database software to protect yourself from known exploits.  Or current as you can.

So a lot depends on your hosting.   DO check your logs and / or mybb sessions table.  Not for everyone I guess, but I like to see what IP's are doing - or trying.  Not a big believer in install and walk away.  Good security comes in layers...
Reply
#3
You'd likely be better off focussing on security at the server level rather than the application level. There also isn't a silver bullet single solution that can be installed to fully protected from hackers, as an exploit could be found in several layers (application, server OS, server software, network etc).
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#4
See also: https://docs.mybb.com/1.8/administration...rotection/
devilshakerz.com/pgp (DF3A 34D9 A627 42E5 BC6A 6750 1F2F B8AA 28FF E1BC) ▪ keybase.io/devilshakerz
Reply
#5
this forum still alive, search for CVE on exploit-db.com, 0day.today, and https://www.cvedetails.com/vulnerability...7fc79b194e
Reply
#6
(2021-06-16, 09:29 AM)Jackson5324 Wrote: this forum still alive, search for CVE on exploit-db.com, 0day.today, and https://www.cvedetails.com/vulnerability...7fc79b194e

Not sure what forum you refer - this one?  Most recent exploits I see on the CVE Details search are pre-1826.  Acknowledged on github with corresponding 1826 release notes.

Exploit-DB search - no joy whatsoever.  Mind you - not as diligent on this stuff as I was years ago.  Toungue
Reply
#7
Check out the Bad Behavior plugin, updated by Omar for MyBB 1.8.*. ( Thanks Omar).

https://github.com/Sama34/MyBB-Bad-Behavior
https://community.mybb.com/thread-94101.html

I run this on my forum to add an extra layer of restrictions, among other things. It works well so far.

There is also a default whitelist that you should edit to suit your own forum.
https://github.com/Sama34/MyBB-Bad-Behav...telist.ini

--

Also install DVZ Hash ( Thanks Devilshakerz ) .

https://community.mybb.com/thread-226036.html
https://community.mybb.com/mods.php?action=view&pid=976
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)