Not Solved 403 in install/upgrade.php [1.8.6 to 1.8.27]
#1
Not Solved
[SOLVED] - I upgraded forum three times - 1.8.6 to 1.8.7 -> 1.8.8 -> 1.8.23, now it works. Later I will try to update it to 1.8.27.

Hello. 

I am trying to upgrade my forum from 1.8.6 version to the newest one, 1.8.27. The problem is, that when I try to click "upgrade" (which sends me to link example.com/install/upgrade.php) I get 500 error. I have changed attributes of upgrade.php to 777, and now it shows me an error:


403
Forbidden
Access to this resource on the server is denied!


In root I have .htaccess file with a part:


<IfModule mod_security.c>
# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule> 



inside, but it doesn't help. What can I do now?


PS What is interesting - in backup, when I access update.php for 1.8.6 update, the page loads without a problem.

Thanks for help.


EDIT:
Also, my host turned off mod_security for my domain, and it still doesn't work.
Reply
#2
Not Solved
You'll need to work with your host to see if there's any other logs with details on what's caused the error. We've not had any other reports of this so sounds like an isolated issue to your hosting environment.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#3
Not Solved
Thanks for answering my question.

I have another one - is there any way to upgrade forum manually, without the script?

SOLVED! (in first post)
Reply
#4
Not Solved
Not really, no. The upgrade scripts run various queries and rebuild other data on the forum, it would be extremely complicated and time consuming to try and do it all manually.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)