[Pushed] [split] Viewing a user IP address in ACP doesn't work with MyBB 1.8.27
#1
Problem reported and confirmed with 1827.

Viewing a user IP address in ACP - Find Users, Options, Show IP addresses - Options - Show Users that have registered with this IP OR Show Users that have posted with this IP - returns all users.

Using PHP 7.3.28.  Workaround - use IP search in modcp.

Edit:  Should've started another thread.  If the mods could do the honours.  Blush 
Subject - 1827 ACP IP search
Reply
#2
According to the build_users_view() fucntion, this is not an OR but an AND search condition.

I think this table could get a table description added to clarify this.
Reply
#3
Not to confuse the issue, but my OR is either RegIP OR PostedWithIP.  Being 2 of the 4 options available:

   

For giggles - reverted /admin/modules/user/users.php to 1826 version.  Worked as expected.

This in my test system, and no regression testing otherwise done.  Query appears identical (999.999.999.999 being obfuscated IP):

/admin/index.php?module=user-users&results=1&action=search&conditions=a%3A1%3A%7Bs%3A5%3A%22regip%22%3Bs%3A14%3A%22999.999.999.999%22%3B%7D

At any rate, not a huge issue.  Most of our staff use the modcp anyway to look up IP duplicates. Wink
Reply
#4
Hi,

Thank you for your report. We have pushed this issue to our Github repository for further analysis where you can track our commits and progress with fixing this bug. Discussions regarding this bug may also take place there too.

Follow this link to visit the issue on Github: https://github.com/mybb/mybb/issues/4400

Thanks for contributing to MyBB!

Regards,
The MyBB Group
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)