Not Solved [How To?] Fix member.php http post duplication
#1
Not Solved
Whenever u register HTTP request (method post) is duplicated and I need to get it fixed asap, any ideas?

PHP mail was causing this, switched to smtp and it worked.
Reply
#2
Not Solved
What do you mean by duplicated? Can we have your URL?
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#3
Not Solved
(2021-08-04, 08:01 PM)Matt Wrote: What do you mean by duplicated? Can we have your URL?

forum.robloxscripts.com

When u register, it will send an HTTP post twice, which means the first tit is going to create an account, and the second time it's going to show u error that the account is already created/u failed captcha.
Reply
#4
Not Solved
Have you edited any core files? Looking at the registration code, it would be impossible for it to do what it's doing unless the code had been modified. Either that, or you have a plugin that is changing how registration works.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#5
Not Solved
(2021-08-04, 10:24 PM)Matt Wrote: Have you edited any core files? Looking at the registration code, it would be impossible for it to do what it's doing unless the code had been modified. Either that, or you have a plugin that is changing how registration works.

member.php was not edited, and I only applied core changes for plugins like google SEO, etc (Plugins that had under plugin name button that core changes are missing). I've been also looking through plugins for keywords like member_register and member_do_register
Reply
#6
Not Solved
Can you go to ACP > Tools & Maintenance > File Verification and run this? If this comes back clear (or only has expected changes), and if hat doesn't flag any issues, go to ACP > Configuration > General Configuration > Disable All Plugins > Yes, then try registering again?
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#7
Not Solved
(2021-08-05, 11:06 AM)Matt Wrote: Can you go to ACP > Tools & Maintenance > File Verification and run this? If this comes back clear (or only has expected changes), and if hat doesn't flag any issues, go to ACP > Configuration > General Configuration > Disable All Plugins > Yes, then try registering again?

In file verification, it only detected changed files (pretty much everything is fine) and I can't register with disabled plugins because I get a SQL error (due to some plugin)
Reply
#8
Not Solved
What plugins do you have? Can you PM me FTP login details? You have to have something here significantly changing how registration works.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#9
Not Solved
(2021-08-05, 12:00 PM)Matt Wrote: What plugins do you have? Can you PM me FTP login details? You have to have something here significantly changing how registration works.

I pmed you
Reply
#10
Not Solved
For visibility, it seems there is an internal double request on the server, not visible client-side in Chrome dev tools, as the server log shows 2 HTTP requests, one with a 499 response. It does seem slow when submitting a valid registration, so looks like it's doing something server-side and doubling the request.
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)