Not Solved Database backups failing to start
#1
Not Solved
When I back up my board's data, I'll usually do the following: 

 - Select all tables (except Private Messages)
 - File Type: GZIP Compressed
 - Save Method: Download
 - Backup Contents: Structure and Data
 - Analyze and Optimize Selected Tables: Yes

Prior to the upgrade to MyBB 1.8.27, this worked just fine for me. However, after the upgrade, backups using the above settings simply fail to start: they trigger an "ERR_INVALID_RESPONSE". 

After some experimentation, I found that the above backup worked just fine if I excluded the Posts table. However, this really isn't very good, because the posts (over 200,000 of them) are the main thing that I'd *want* to back up. 

I then experimented a little more, and found the following settings, which do work:

 - Select only the 'Posts' table
 - File Type: Plain Text
 - Save Method: Download
 - Backup Contents: Data Only
 - Analyze and Optimize Selected Tables: No


This enabled me to back up all of my posts. However, it does mean that I have to take three separate backups in order to back up all of my board's content (a Plain Text backup of my posts, a backup of the 'Posts' structure, and a GZIP Compressed backup of everything else). That's obviously not ideal. 

So, does anybody know why these backups might be failing to start now?
Reply
#2
Not Solved
Your backup probably fail because of some limitation you may have on your DB, as a connection timeout or slow queries.
Try contacting your hoster to know if he have some logs of fails to understand what happen and how to fix that (db / account tuning)
Do not ask me help through PM or Discord
Reply
#3
Not Solved
Either that, or just a web server timeout issue. Chrome will show that page if it doesn't get a response after a certain time (sometimes it will still download the file eventually if it doesn't close the connection). The backup script hasn't changed in years so it won't be related to 1.8.27, it'll just be happening now due to the size of the database. I think usually once a database gets to a certain size, we'd recommend command line backups with mysqldump anyway: https://docs.mybb.com/1.8/administration...ly-backups
MyReactions - All Plugins

Can you still feel the butterflies?

Free never tasted like pudding.
Reply
#4
Not Solved
Well, the good news is that backing up via cPanel works correctly, so I guess I'll just have to do that from now on (or rather, have my friend do it, since my board is on her hosting Toungue ).

Odd that this happened just as I upgraded to MyBB 1.8.27, but I guess coincidences do happen, and it sounds like this was one of them (but I thought I should ask anyway!)

Thanks for the support, guys Smile .
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)