Solved: 1 Year, 2 Weeks ago MyBB rejects all registrants as spammers
#1
Solved: 1 Year, 2 Weeks ago
After a recent upgrade, I've learned that my small forum is rejecting all new registrations with the message.

Our systems detect that you may be a spammer and therefore you have been denied registration. If you feel this is a mistake, please contact the Administrator.

Doesn't seem to matter the input, the result is the same.
I don't have Honeypot added, I've deactivated mybb's built-in CAPTCHA, all board settings for Login and Registration Options are set to "NO" save for 'awaiting activation', 'failed logins' and 'Security Question'....but the login never even gets to the security question.

I see this issue described at https://community.mybb.com/thread-108796.html, but the solution did not apply: my 'Display a hidden CAPTCHA' was already set to 'NO'.

Does anyone have any further suggestions as to what might be triggering this response?
Reply
#2
Solved: 1 Year, 2 Weeks ago
Is the problem resolved when in the ACP's Board Settings you set Login and Registration OptionsMinimum Registration Time to zero?

If so, we haven't identified the root cause, but we might be on the way towards discovering it.
Reply
#3
Solved: 1 Year, 2 Weeks ago
Bingo, Laird.
That nailed it. Big Grin
I would not have thought to change that setting myself.

When and if you do identify the root cause, how will we mybb users know? Huh
Reply
#4
Solved: 1 Year, 2 Weeks ago
Glad to hear that that solved the problem for you.

Re the root cause: the thing is that it is specific to your board, because the rest of us don't experience the same problem (Minimum Registration Time is set to 15 on the main board I administer, and folk can still register).

If you want to debug the root cause on your board, then we can do that. My guess is that the line:
<input type="hidden" name="regtime" value="{$time}" />
has been removed from your member_register template, or otherwise disabled, or that in some way that regtime form field isn't getting passed to member.php on submission of registration.

Hopefully that gives you something to go on in your investigations!
Reply
#5
Solved: 1 Year, 2 Weeks ago
thanks again, Laird.

Yes, that line was indeed missing from the member_register template.
I've added it in a location that seems appropriate:

<div align="center">
<input type="hidden" name="step" value="registration" />
<input type="hidden" name="action" value="do_register" />
<input type="hidden" name="regtime" value="{$time}" />
<input type="submit" class="button" name="regsubmit" value="{$lang->submit_registration}" />
</div>

This does seem to work, allowing me to restore the 'minimum time' to the default 15 seconds.

Your guess appears to have been correct once again!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)