Not Solved Threadlog having issues!
#1
Not Solved
Happening here: Click!
And any other threadlog on the site.

My problem is that it doesn't display their username unless they have threads posted to the threadlog.
My second problem is that the threadlog doesn't display threads the user hasn't authored themselves. It only displays threads they wrote.
Third problem — it doesn't display any past threads from before the plugin was installed.

Any ideas what the fixes would be to these? Any input is welcome, just please don't bash me for not fixing it if it's an easy fix.
Reply
#2
Not Solved
Where'd you download the plugin from? Here? https://github.com/amwelles/mybb-threadlog
Reply
#3
Not Solved
(2021-11-19, 01:49 AM)Laird Wrote: Where'd you download the plugin from? Here? https://github.com/amwelles/mybb-threadlog

Yes!
Reply
#4
Not Solved
OK. Good! We've got something to work with.

I haven't installed or tested the plugin yet, but I can immediately see the source of the first problem just from a visual inspection:

If the query starting on line 444 doesn't return any results (your situation), or, rather, its counts are all zero, then $counts['username'] on line 461 will be empty, or NULL more specifically (hence there will be no username to display, as you are experiencing).

You could, I think, get around this problem by replacing that $counts['username'] with get_user($uid)['username'], but that's untested code and might not work.

As for the other two problems, they would take a bit more digging to investigate. I wonder: have you tried to contact the plugin's author?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)