Group permissions not applied when forum is custom
#1
Hi there,

Due to spammers posts, I decided to force the registered group to have its new posts and threads to be moderate. But I've modified some permissions on forums (to remove the hability of posting polls to everyone), and the changements I did on the group are not applied on the forum, unless I remove the forum permissions and re-apply them.

I think I already noticed and mentionned this kind of trouble with the group and forum custom permission.
Do not ask me help through PM or Discord
Reply
#2
The set of a usergroup's group permissions is the default permission configuration for any forum (and category) if the forum and any of its ancestral forums doesn't have a custom permission configuration for this group.

Here, a custom permission configuration for a group for a forum is the set of forum permissions of this usergroup for the forum, which means if there is one forum permission for this usergroup for a specific forum is custom, all other forum permissions of the usergroup for the forum is configured.

With that knowledge, can you confirm the issue?
Could be wrong but worth a try.
Email me at: [email protected]
Reply
#3
Well, I understand and so it's not an issue, but most of admins will be surprised to see that modifying usergroups permissions don't take effect when custom permissions are set on forums.

I'll probably work on an admin plugin to help populate usergroups settings to forums, or warn when (and where) settings on groups won't be used
Do not ask me help through PM or Discord
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)