Solved: 3 Months, 2 Weeks, 6 Days ago Problems with attachments not working
#1
Solved: 3 Months, 2 Weeks, 6 Days ago
Hello All.

I've been using 1.8.21 for some time and had problems with image attachments not showing for some users
while logged in, and file attachments not accessible while logged in.  Log out & the images are viewable and
attachments then work.
This has only been for some users for some reason, seemingly independent of which browser they use.

Today I've upgraded my install from 1.8.21 -> 1.8.30 (with all intermediate versions on the way) and now I am 
no longer able to see images attached to posts or click on links for file attachments and have them work.
Additionally, 'View a Printable version' of a thread gives me a blank page with 
' ..../forum/printthread.php?tid=523 ' in the address bar.
This is the same as when I click on a link for an attached file which gives a new [blank] browser window with 
' ..../forum/attachment.php?aid=421 ' in the address bar.

I've checked permissions under (for example) groups -> registered -> Forums & Posts -> Viewing Options ->
Can download attachments? [ticked ] and all appear to be as required.

Any suggestions?

Forum URL :  www.microbeetechnology.com.au/forum/

Thanks in advance.
Reply
#2
Solved: 3 Months, 2 Weeks, 6 Days ago
https://community.mybb.com/thread-215173...pid1294391

^ See if this might be of some help to you. Smile

(2018-01-07, 10:38 AM).m. Wrote: basically the problem was due to Byte Order Mark / white space at the beginning of a plugin file.
the issue was checked & cleaned by using PHP Files Cleaner plugin
Reply
#3
Solved: 3 Months, 2 Weeks, 6 Days ago
Thanks Taylor M

I had a look at that thread and the github post.
I don't have any plugins active. I tried the PHP Files Cleaner plugin anyway and
[logically] it didn't find any files to clean.

I did wonder if it was something to do with a Theme I'm using, but I tried the default one and it is the same.

Still stumped.

Problem Solved.

There were a number of corrupt files in the install that might have been broken during the upgrade(s).
I didn't read the bit about turning the forum off or using .htaccess to deny visitors during the upgrade.
Anyway, I ran the file verification checker in ACP and it showed my that around 10 files were corrupt including
attachment.php I downloaded the full install & uploaded the corrupt / missing files to my forum, turned the forum
back on & all good now.
Case Closed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)