Not Solved [General] Posts not appearing when opening a topic
#1
Not Solved
When you copy and paste texts from another site, the text becomes too small to be seen with the naked eye.


Attached Files Thumbnail(s)
   
Reply
#2
Not Solved
Some websites format type size in points. MyBB formats type size in named sizes. Copy/paste will bring formatted text over, such that size=2 will be interpreted by the browser as 2 point type which is too small to be read.

Toggle source mode before pasting by clicking the last icon on the right of the editor tool bar. Copy pasted will have formatting stripped out.

Or, edit the post to remove any size=xx /size codes.

A similar problem occurs when formatted text has color specified which might make it unreadable using a theme with a dark background. I use a Drop Color mycode replacement where regular expression
\[\/?color[^\]]*\]
gets replaced with blank string.
Reply
#3
Not Solved
Your editor is in source mode by default which HLFadmin explained what that does.

You can globally change this for ALL users, to ensure the editor will always be in source mode, by finding this section of code in Ungrouped Templates > codebuttons:
MyBBEditor = $("#{$bind}").sceditor("instance");
 {$sourcemode}
And changing it to this:
MyBBEditor = $("#{$bind}").sceditor("instance");
 //{$sourcemode}
 MyBBEditor.sourceMode(true);

Alternatively you can inform your members that they can control this and turn on source mode in their User CP > Edit Options > Other Options and then check marking "Put the editor in source mode by default." OR when pasting your content into the editor right click and "Paste as plain text" instead of the normal "Paste" option.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)