Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update naar 1212 - lettertekens verkeerd weergegeven
#1
Daarnet geupdate naar de laatste versie 1212 - alles verliep zonder problemen.
Alsook de global.lang.php+dutch.php heb ik geupdate voor de Nederlandse versie.
Nu bemerk ik dat sommige leestekens verkeerd worden weergeven... de é wordt een ? in Firefox. In IE geeft dit een vierkantje weer.
Voor de update werkte alles nog prima.

Heb nog even extra nagekeken bij de instellingen in ACP voor decimaalteken (die een komma is) en Cijfergroeperingssymbool (die een punt is) - dus deze staan OK.
Ik kan voor de rest niet meteen vinden hoe dit weer te herstellen...
Microsoft MVP - Consumer Security
#2
Ook gemerkt dat nu in ACP, bij instellingen, waar Categorieën links staat, dat er nu een vraagteken rechts staat. (Daar waar in het Engels "options" moet staan).

Edit: Als ik de "ongekende lettertekens" manueel wijzig op het forum naar de juiste letter, dus bv ? terug veranderen naar é, dan worden deze behouden en worden ze juist weergegeven. Dus het komt erop neer dat de sommige lettertekens na de update verkeerd werden weergegeven, maar als je ze wijzigt, dan worden ze "behouden"
Microsoft MVP - Consumer Security
#3
Als bijlage bij dit bericht heb ik een nieuwe versie van dutch.php bijgevoegd. Hopelijk lost dit het probleem op. (Ironisch genoeg had ik juist een aanpassing aan dit bestand gemaakt om soortgelijke problemen op te lossen -- ik zal binnenkort nog eens goed kijken wat er precies fout gaat Smile).


Attached Files
.php   dutch.php (Size: 1,004 bytes / Downloads: 239)
#4
Hmm, nu ziet het er nog leuker uit Big Grin
Eerder was dit Kletscaf?, nu is het Kletscafé
Maar zoals ik al eerder heb gepost, ik kan de woorden gewoon terug wijzigen en ze worden behouden.
Blijkt dat deze verandering zich gewoon voordoet wanneer je de dutch.php wijzigt - overschrijft. Ieder woord die ik nadien ingeef wordt correct weergegeven.

Ik herinner mij dat bij het installeren van MyBB, toen ik de eerste keer het Nederlands taalpakket had geupload, dat ik ook dit probleem had. Toen heb ik gewoon de woorden gewijzigd en alles was ok.
Microsoft MVP - Consumer Security
#5
Vage zaak. Zoals ik zei zal ik er over niet al te lange tijd nog eens naar kijken Smile
#6
Ok, dan lees ik het hier wel.

Alvast bedankt Smile
Microsoft MVP - Consumer Security
#7
Dit bestand werkt tot zover nog bij mij.


Attached Files
.php   dutch.php (Size: 961 bytes / Downloads: 248)
[Image: destroyerjf8.jpg]

Give us your feedback about MyBB in this thread and become listed on the MyBB website.
#8
Ik denk dat ik al weet wat dit verklaart... in de eerste versie van dutch.php was de characterset gezet naar UTF-8, dus daarom werden de tekens verkeerd weergegeven. Aangezien daarna de dutch.php terug werd gewijzigd naar iso-8859-1, en ik die overschreven heb, werd er een poging gedaan om de verkeerd weergegeven tekens (vierkantjes en vraagtekens) die eerder aanwezig waren terug te herstellen, maar iso-8859-1 kan deze vierkantjes en vraagtekens niet "parsen", dus dat verklaart waarom de tekens nadien nog vreemder waren Smile
In ieder geval, met iso-8859-1 gezet als characterset zou dit probleem niet meer in de toekomst aanwezig zijn Smile
Microsoft MVP - Consumer Security
#9
Dat verklaart inderdaad jouw probleem, maar nog niet waarom andere mensen juist problemen hadden met de iso-8859-1-codering (immers, ik had het naar UTF-8 veranderd omdat iemand juist met iso-8859-1 problemen had). Blij dat dit het probleem lijkt op te lossen Smile

Destroyer: het door jou geüploade bestand is qua codering identiek aan het door mij geüploade bestand. Het enige verschil is dat de combatibiliteit van jouw versie op 1210 staat (dat wil zeggen, geschikt voor MyBB 1.2.10) en bij mijn versie 1212 is (voor MyBB 1.2.12), het verschil in bestandsgrootte wordt veroorzaakt door extra commentaar in mijn versie. In de praktijk zouden beide bestanden gewoon moeten werken Wink
#10
Quote:Dat verklaart inderdaad jouw probleem, maar nog niet waarom andere mensen juist problemen hadden met de iso-8859-1-codering
Dat komt waarschijnlijk omdat men in ACP het decimaalteken en Cijfergroeperingssymbool dit niet heeft gewijzigd, want tenslotte voor Nederlands is het net omgekeerd dan Amerikaans/Engels.
Enfin, toen ik dit eerder had, de eerste keer dat ik MyBB had geïnstalleerd, had ik ook vreemde charactersets, maar na het wijzigen van decimaalteken etc in ACP was dit gefixt - daarom denk ik dat het daar toen ergens mee te maken had....
Microsoft MVP - Consumer Security


Forum Jump:


Users browsing this thread: 1 Guest(s)