Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[F] PunBB - passwords and administrator permissions
Glad this was pinpointed. I really haven't had trouble except for that password conversion thing. You da man for figuring it out Tikitiki sir. (no mention of merge system)

However this is excellent if you search:

Might be a good idea to either add a link to that wiki entry on the download page:

Or make it a readme.html file that's part of the download itself.

My suggestion is only to help with new users of Mybb. We must keep in mind that they are unfamiliar with every aspect of mybb...from it's code to it's help formats. Anything to simplify for new users should be done imho.

Thanks again sir.
Thanks Tikitiki!

Is the next version of the Merge System gonna be released soon?
Do I just need to massively search and replace strlen with my_strlen to fix it myself? Or just in some files and places?

Maybe could you please send me the fix so I don't have to wait until RC4 to get my board converted? That would save me some precious time! ^^
It's already fixed for you and the download on the MyBB site.
Sorry to bump this thread again. But I'm currently having this issue. I'm in the progress of migrating my punbb forum to mybb

1. I have punbb 1.2.21 with few members and few topics in 2 categories in local server.
2. installed mybb_1214
3. copy over mybb_merge_3682 convert folder to ./
4. manually copy loginconvert.php to ./inc/plugins
5. Using administrator, activated it.
6. Perform /convert
7. Everything's fine.
8. After conversion, my administrator id lost its privileges. No more access to admin cp.
9. Before that created another id called admin2 with administrator privileges, but no luck as well.

I believe I had read this thread more than 10x, but I'm still confused. I checked the my_strlen and it was correct.

Please help me if there is another way to fix this issue.

I've tried to go straight from 1.4.4 with svn converter, everything went fine till the 'thread section'. Please have a look at the screenshot.


I tried to compare the old rc3 with the svn and I wonder if this is the possible cause to the admin privilege lost, although I've no idea about the programming side.
Update: Since the little error, I managed to replace the current code in line 1219
$query = $this->old_db->simple_select("users", "id, username", "username = '".$db->escape_string($username)."'", array('limit' => 1));
$query = $this->old_db->simple_select("users", "id, username", "username = '{$username}'", array('limit' => 1));
from original code in merge_3682 line 1310
$query = $this->old_db->simple_select(PUNBB_TABLE_PREFIX."users", "id, username", "username = '{$username}'", array('limit' => 1));
notice I remove PUNBB_TABLE_PREFIX and "username = '".$db->escape_string($username)."'" which cause the error..

Everything turns out fine *so far.. my admin has the privilege to access admin CP and every topic and post turned out fine. But I just wanna be clarified before I go full conversion on my board.

Please give some enlightment?

Forum Jump:

Users browsing this thread: 1 Guest(s)